summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2012-05-08 10:31:57 +0000
committerDirkjan Ochtman <djc@gentoo.org>2012-05-08 10:31:57 +0000
commitfa646b65d87b647ed57f6b8106647b8e925a5c5f (patch)
treefe9ddf3c498cddd0d55765e463e39efe57de4208 /dev-python/setproctitle/setproctitle-1.1.6.ebuild
parentUse http instead of ftp in SRC_URI to avoid possible firewall issues. Fixes #... (diff)
downloadgentoo-2-fa646b65d87b647ed57f6b8106647b8e925a5c5f.tar.gz
gentoo-2-fa646b65d87b647ed57f6b8106647b8e925a5c5f.tar.bz2
gentoo-2-fa646b65d87b647ed57f6b8106647b8e925a5c5f.zip
Version bump setproctitle to 1.1.6.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/setproctitle/setproctitle-1.1.6.ebuild')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.6.ebuild b/dev-python/setproctitle/setproctitle-1.1.6.ebuild
new file mode 100644
index 000000000000..22eaa4b04d1b
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.6.ebuild,v 1.1 2012/05/08 10:31:57 djc Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="HISTORY.rst README.rst"
+
+src_prepare() {
+ python_copy_sources
+
+ conversion() {
+ [[ "${PYTHON_ABI}" == 2.* ]] && return
+ 2to3-${PYTHON_ABI} -w --no-diffs tests > /dev/null
+ }
+ python_execute_function \
+ --action-message 'Applying patches for $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Applying patches for $(python_get_implementation) $(python_get_version) failed' \
+ -s conversion
+}
+
+distutils_src_test_pre_hook() {
+ local version=$(python_get_version -l --major)
+ ln -fs pyrun-${PYTHON_ABI} tests/pyrun${version}
+}
+
+src_test() {
+ build_pyrun() {
+ echo $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -I$(python_get_includedir) -o tests/pyrun-${PYTHON_ABI} tests/pyrun.c $(python_get_library -l)
+ }
+ python_execute_function -q -s build_pyrun
+
+ distutils_src_test
+} \ No newline at end of file