summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-16 06:39:28 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-16 06:39:28 +0000
commit995672b70c32a7e1d88274252f74e00f4311ee48 (patch)
tree99db109a763efc87bae2809f500364e460c6139f /dev-python/scimath
parentrepoman fixes (diff)
downloadgentoo-2-995672b70c32a7e1d88274252f74e00f4311ee48.tar.gz
gentoo-2-995672b70c32a7e1d88274252f74e00f4311ee48.tar.bz2
gentoo-2-995672b70c32a7e1d88274252f74e00f4311ee48.zip
drop old -3.0.7, migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/scimath')
-rw-r--r--dev-python/scimath/ChangeLog8
-rw-r--r--dev-python/scimath/scimath-3.0.7.ebuild39
-rw-r--r--dev-python/scimath/scimath-4.1.2-r1.ebuild47
3 files changed, 54 insertions, 40 deletions
diff --git a/dev-python/scimath/ChangeLog b/dev-python/scimath/ChangeLog
index 690b313f64b0..17bbcc481831 100644
--- a/dev-python/scimath/ChangeLog
+++ b/dev-python/scimath/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/scimath
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.14 2013/04/03 08:50:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/ChangeLog,v 1.15 2013/04/16 06:39:28 idella4 Exp $
+
+*scimath-4.1.2-r1 (16 Apr 2013)
+
+ 16 Apr 2013; Ian Delaney <idella4@gentoo.org> +scimath-4.1.2-r1.ebuild,
+ -scimath-3.0.7.ebuild, scimath-4.1.2.ebuild:
+ drop old -3.0.7, migration -> distutils-r1
*scimath-4.1.2 (03 Apr 2013)
diff --git a/dev-python/scimath/scimath-3.0.7.ebuild b/dev-python/scimath/scimath-3.0.7.ebuild
deleted file mode 100644
index 793f1c2f807a..000000000000
--- a/dev-python/scimath/scimath-3.0.7.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-3.0.7.ebuild,v 1.2 2012/02/24 09:40:50 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-DISTUTILS_SRC_TEST="setup.py"
-
-inherit distutils
-
-MY_PN="SciMath"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
-HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/SciMath"
-SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/enthoughtbase-3.1.0
- >=dev-python/numpy-1.1
- >=dev-python/traits-3.6.0
- >=dev-python/traitsgui-3.6.0[wxwidgets]
- sci-libs/scipy"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? (
- >=dev-python/etsdevtools-3.1.1
- dev-python/nose
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="enthought"
diff --git a/dev-python/scimath/scimath-4.1.2-r1.ebuild b/dev-python/scimath/scimath-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..270d30911f4c
--- /dev/null
+++ b/dev-python/scimath/scimath-4.1.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/scimath/scimath-4.1.2-r1.ebuild,v 1.1 2013/04/16 06:39:28 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific and mathematical tools"
+HOMEPAGE="http://code.enthought.com/projects/sci_math/ http://pypi.python.org/pypi/scimath"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND=">=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4.1[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # ONE test assumes PYTHONPATH in its own dir!!! ! !! !
+ PYTHONPATH=build/lib/:build/lib/scimath/interpolate/
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/build/html/*
+}