summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-01-11 08:16:45 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-01-11 08:16:45 +0000
commitc2be3fb5b48f472bc8a9bcdd856bfae3ba4cc924 (patch)
tree6379bc41638b0c6064c9100a4ded2ac6f612d43d /dev-python/restkit
parentx86 stable wrt bug #350587 (diff)
downloadgentoo-2-c2be3fb5b48f472bc8a9bcdd856bfae3ba4cc924.tar.gz
gentoo-2-c2be3fb5b48f472bc8a9bcdd856bfae3ba4cc924.tar.bz2
gentoo-2-c2be3fb5b48f472bc8a9bcdd856bfae3ba4cc924.zip
Version bump (bug #348311).
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/restkit')
-rw-r--r--dev-python/restkit/ChangeLog9
-rw-r--r--dev-python/restkit/restkit-2.3.3.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-python/restkit/ChangeLog b/dev-python/restkit/ChangeLog
index ecf38f778ac9..d030857c0068 100644
--- a/dev-python/restkit/ChangeLog
+++ b/dev-python/restkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/restkit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.2 2010/11/15 15:48:17 dev-zero Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.3 2011/01/11 08:16:45 dev-zero Exp $
+
+*restkit-2.3.3 (11 Jan 2011)
+
+ 11 Jan 2011; Tiziano Müller <dev-zero@gentoo.org> +restkit-2.3.3.ebuild:
+ Version bump (bug #348311).
*restkit-2.2.3 (15 Nov 2010)
diff --git a/dev-python/restkit/restkit-2.3.3.ebuild b/dev-python/restkit/restkit-2.3.3.ebuild
new file mode 100644
index 000000000000..79e357dcc790
--- /dev/null
+++ b/dev-python/restkit/restkit-2.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-2.3.3.ebuild,v 1.1 2011/01/11 08:16:45 dev-zero Exp $
+
+EAPI=3
+
+DISTUTILS_SRC_TEST="nosetests"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3*"
+
+inherit distutils
+
+DESCRIPTION="A HTTP ressource kit for Python."
+HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+cli doc examples"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx
+ dev-python/epydoc )
+ test? ( dev-python/webob )"
+RDEPEND="cli? ( dev-python/ipython
+ dev-python/setuptools )"
+
+DOCS="NOTICE README.rst TODO.txt doc/*.rst"
+
+# TODO
+# - optionally depend on gevent and/or eventlet
+
+src_prepare() {
+ # remove failing tests, https://github.com/benoitc/restkit/issues#issue/43
+ rm "${S}/tests/010-test-proxies.py"
+
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd doc
+ PYTHONPATH="${S}" emake html || die "building docs failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use cli || rm "${D}"/usr/bin/restcli*
+
+ use doc && dohtml -r doc/_build/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}