summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-19 07:38:46 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-19 07:38:46 +0000
commit6cbe202ee78274c680808306c123041f0b16f71a (patch)
tree9eaa5b8efa0bfd9d892eb1f11e6dc279cb6ad506 /dev-python/quixote/quixote-2.8.ebuild
parentVersion bump. (diff)
downloadgentoo-2-6cbe202ee78274c680808306c123041f0b16f71a.tar.gz
gentoo-2-6cbe202ee78274c680808306c123041f0b16f71a.tar.bz2
gentoo-2-6cbe202ee78274c680808306c123041f0b16f71a.zip
bump; add IUSE doc, test. Tests restricted due to need for a running server
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/quixote/quixote-2.8.ebuild')
-rw-r--r--dev-python/quixote/quixote-2.8.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/quixote/quixote-2.8.ebuild b/dev-python/quixote/quixote-2.8.ebuild
new file mode 100644
index 000000000000..b5e8e1fdceda
--- /dev/null
+++ b/dev-python/quixote/quixote-2.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/quixote/quixote-2.8.ebuild,v 1.1 2014/05/19 07:38:46 idella4 Exp $
+
+EAPI=5
+# Appears to be written only for py2
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+MY_P="${P/q/Q}"
+
+DESCRIPTION="Python HTML templating framework for developing web applications"
+HOMEPAGE="http://quixote.ca"
+SRC_URI="http://quixote.ca/releases/${MY_P}.tar.gz"
+
+LICENSE="CNRI-QUIXOTE-2.4"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc test"
+
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
+# tests require a running quixote server, prob. apt. post install. Tried the demo one but no
+RESTRICT="test"
+
+python_compile() {
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C doc
+}
+
+python_test() {
+ nosetests tests || die "tests failed"
+}
+
+python_install_all() {
+ local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}