summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 20:28:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 20:28:35 +0000
commitc220f33e1157ca1fe629bae8d4898e7515ce57a4 (patch)
treefed68fd778f4f57b0f51aa32ceee79b961b3a2f9 /dev-python/qscintilla-python
parentRemove old versions. (diff)
downloadgentoo-2-c220f33e1157ca1fe629bae8d4898e7515ce57a4.tar.gz
gentoo-2-c220f33e1157ca1fe629bae8d4898e7515ce57a4.tar.bz2
gentoo-2-c220f33e1157ca1fe629bae8d4898e7515ce57a4.zip
Eapi2ification. USE-Deps for the win.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/qscintilla-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog8
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index ff3e741eca27..d53bb0f28c6d 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.20 2009/02/20 17:53:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.21 2009/03/07 20:28:35 patrick Exp $
+
+*qscintilla-python-2.3.2-r1 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +qscintilla-python-2.3.2-r1.ebuild:
+ Eapi2ification. USE-Deps for the win.
20 Feb 2009; Jeroen Roovers <jer@gentoo.org>
qscintilla-python-2.3.2.ebuild:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..89d6afe68440
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.3.2-r1.ebuild,v 1.1 2009/03/07 20:28:35 patrick Exp $
+
+EAPI="2"
+
+inherit eutils python
+
+MY_PN="qscintilla"
+MY_P="${MY_PN/qs/QS}-gpl-${PV}"
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/QScintilla2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt4"
+
+DEPEND=">=dev-python/sip-4.4
+ =x11-libs/qscintilla-${PV}*[qt4?]
+ qt4? ( >=dev-python/PyQt4-4.4 )
+ !qt4? ( >=dev-python/PyQt-3.17.6 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+#pkg_setup() {
+# # this package needs to have same qt flags with qscintilla.
+# if use qt4; then
+# if ! built_with_use 'x11-libs/qscintilla' 'qt4'; then
+# eerror "Please build qscintilla with qt4 useflag."
+# die "qscintilla built without qt4."
+# fi
+# else
+# if built_with_use 'x11-libs/qscintilla' 'qt4'; then
+# eerror "Please build qscintilla without qt4 useflag."
+# die "qscintilla built with qt4"
+# fi
+# fi
+#}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.2-nostrip.patch
+}
+
+src_configure() {
+ local myconf="-o /usr/lib -n /usr/include"
+ if use qt4; then
+ myconf="${myconf} -p 4"
+ else
+ myconf="${myconf} -p 3"
+ fi
+
+ python_version
+ ${python} configure.py ${myconf} || die "configure.py failed"
+}
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+}