summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2008-12-13 23:12:14 +0000
committerJesus Rivero <neurogeek@gentoo.org>2008-12-13 23:12:14 +0000
commitff5d14007cfcd157fe9e94b71f341abebfbed3b5 (patch)
treeb12cdbbc96b727e665aa0ab0fa8661659413e91b /dev-python/pyxf86config
parentVersion bump for 238575. (diff)
downloadgentoo-2-ff5d14007cfcd157fe9e94b71f341abebfbed3b5.tar.gz
gentoo-2-ff5d14007cfcd157fe9e94b71f341abebfbed3b5.tar.bz2
gentoo-2-ff5d14007cfcd157fe9e94b71f341abebfbed3b5.zip
Revision bump. Added _need_rebuild _mod_compile and _mod_cleanup. Closes Bug #244615
(Portage version: 2.2_rc16/cvs/Linux 2.6.18-gentoo-r3 i686)
Diffstat (limited to 'dev-python/pyxf86config')
-rw-r--r--dev-python/pyxf86config/ChangeLog9
-rw-r--r--dev-python/pyxf86config/pyxf86config-0.3.34-r2.ebuild70
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-python/pyxf86config/ChangeLog b/dev-python/pyxf86config/ChangeLog
index 65854d1c9677..ed6b799432d0 100644
--- a/dev-python/pyxf86config/ChangeLog
+++ b/dev-python/pyxf86config/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyxf86config
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/ChangeLog,v 1.22 2008/10/28 17:00:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/ChangeLog,v 1.23 2008/12/13 23:12:14 neurogeek Exp $
+
+*pyxf86config-0.3.34-r2 (13 Dec 2008)
+
+ 13 Dec 2008; Jesus Rivero <neurogeek@gentoo.org>
+ +pyxf86config-0.3.34-r2.ebuild:
+ Revision bump. Added _need_rebuild _mod_compile and _mod_cleanup. Closes
+ Bug #244615
28 Oct 2008; Markus Rothe <corsair@gentoo.org>
pyxf86config-0.3.34-r1.ebuild:
diff --git a/dev-python/pyxf86config/pyxf86config-0.3.34-r2.ebuild b/dev-python/pyxf86config/pyxf86config-0.3.34-r2.ebuild
new file mode 100644
index 000000000000..12afe4028544
--- /dev/null
+++ b/dev-python/pyxf86config/pyxf86config-0.3.34-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxf86config/pyxf86config-0.3.34-r2.ebuild,v 1.1 2008/12/13 23:12:14 neurogeek Exp $
+
+inherit eutils python rpm autotools
+
+# Tag for which Fedora Core version it's from
+FCVER="8"
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Python wrappers for libxf86config"
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/"
+SRC_URI="mirror://fedora-dev/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-libs/glib-2*
+ dev-lang/python"
+DEPEND="${RDEPEND}
+ >=x11-base/xorg-server-1.1.1-r1"
+
+pkg_setup() {
+ if built_with_use x11-base/xorg-server minimal; then
+ eerror "To build ${PN} you need the libxf86config static library from"
+ eerror "x11-base/xorg-server, which is not built when the minimal USE flag is used."
+ eerror "Please disable the minimal USE flag for x11-base/xorg-server"
+ die "Missing libxf86config.a"
+ fi
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+
+ if has_version '>=x11-base/xorg-server-1.4' ; then
+ epatch "${FILESDIR}/xorg-server-1.4-compat.patch"
+ fi
+
+ # Compat with 1.5
+ epatch "${FILESDIR}"/0.3.34-remove-rgbpath.patch
+
+ # (#206989) Cleaned up Makefile.am that works correctly on amd64
+ cp "${FILESDIR}"/Makefile.am "${S}"/ || die
+ eautoreconf
+}
+
+src_compile() {
+ python_version
+ econf --with-python-version=${PYVER} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ python_mod_compile $(python_get_sitedir)/xf86config.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}