summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 17:35:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-05 17:35:59 +0000
commit6aecd5af2b5e544db3c6d0e5894f4b019a7cf296 (patch)
tree7109a89bacd603023d81bd0b344f74eb2c97474d /dev-python/pyxattr
parentUpdate DESCRIPTION, HOMEPAGE and SRC_URI. (diff)
downloadgentoo-2-6aecd5af2b5e544db3c6d0e5894f4b019a7cf296.tar.gz
gentoo-2-6aecd5af2b5e544db3c6d0e5894f4b019a7cf296.tar.bz2
gentoo-2-6aecd5af2b5e544db3c6d0e5894f4b019a7cf296.zip
Add "test" USE flag and src_test().
(Portage version: 14926-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyxattr')
-rw-r--r--dev-python/pyxattr/pyxattr-0.4.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pyxattr/pyxattr-0.4.0.ebuild b/dev-python/pyxattr/pyxattr-0.4.0.ebuild
index 537a1fc24cf1..9ea526fbbdd6 100644
--- a/dev-python/pyxattr/pyxattr-0.4.0.ebuild
+++ b/dev-python/pyxattr/pyxattr-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.4.0.ebuild,v 1.7 2009/10/25 13:41:48 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyxattr/pyxattr-0.4.0.ebuild,v 1.8 2009/12/05 17:35:59 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -14,9 +14,17 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm ia64 ppc ppc64 sh sparc x86"
-IUSE=""
+IUSE="test"
RDEPEND="sys-apps/attr"
DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc7-r1"
+ >=dev-python/setuptools-0.6_rc7-r1
+ test? ( dev-python/nose )"
RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" nosetests-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}