summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-22 05:42:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-22 05:42:09 +0000
commit1b4add40c090ac51201e6b58417150564addae46 (patch)
tree2fe862bb4d58c0a4de699b1aa1c41a7c4494aae5 /dev-python/python-twitter
parentBump (diff)
downloadgentoo-2-1b4add40c090ac51201e6b58417150564addae46.tar.gz
gentoo-2-1b4add40c090ac51201e6b58417150564addae46.tar.bz2
gentoo-2-1b4add40c090ac51201e6b58417150564addae46.zip
Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/python-twitter')
-rw-r--r--dev-python/python-twitter/ChangeLog10
-rw-r--r--dev-python/python-twitter/python-twitter-0.8.5.ebuild53
2 files changed, 60 insertions, 3 deletions
diff --git a/dev-python/python-twitter/ChangeLog b/dev-python/python-twitter/ChangeLog
index 999ae72caedc..b3ca6c1d40a3 100644
--- a/dev-python/python-twitter/ChangeLog
+++ b/dev-python/python-twitter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-twitter
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/ChangeLog,v 1.9 2012/03/01 09:38:50 djc Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/ChangeLog,v 1.10 2013/02/22 05:42:09 patrick Exp $
+
+*python-twitter-0.8.5 (22 Feb 2013)
+
+ 22 Feb 2013; Patrick Lauer <patrick@gentoo.org> +python-twitter-0.8.5.ebuild:
+ Bump
*python-twitter-0.8.2 (01 Mar 2012)
@@ -56,4 +61,3 @@
05 Oct 2009; Tomas Touceda (chiiph) <chiiph@gmail.org>
+python-twitter-0.6.ebuild, +metadata.xml:
New Ebuild for bug 287529. Thanks sunrise devs for their reviews
-
diff --git a/dev-python/python-twitter/python-twitter-0.8.5.ebuild b/dev-python/python-twitter/python-twitter-0.8.5.ebuild
new file mode 100644
index 000000000000..6b922832640f
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-0.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-0.8.5.ebuild,v 1.1 2013/02/22 05:42:09 patrick Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="This library provides a pure python interface for the Twitter API"
+HOMEPAGE="http://code.google.com/p/python-twitter/"
+SRC_URI="http://python-twitter.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="examples"
+
+RDEPEND="dev-python/oauth2
+ dev-python/simplejson"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+DOCS="CHANGES README.md"
+PYTHON_MODNAME="twitter.py"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Delete internal copy of simplejson.
+ rm -fr simplejson
+}
+
+#Test are disabled because they are broken.
+#See http://code.google.com/p/python-twitter/issues/detail?id=196 for details.
+#src_test() {
+# testing() {
+# PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" twitter_test.py
+# }
+# python_execute_function testing
+#}
+
+src_install() {
+ distutils_src_install
+
+ dohtml doc/twitter.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}