summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2006-02-27 01:25:30 +0000
committerChris PeBenito <pebenito@gentoo.org>2006-02-27 01:25:30 +0000
commit00cebb424c14445802e042aef3a08e139e6b494a (patch)
tree4b23c214f29081e9235070fc49a6fe829e0445a9 /dev-python/python-selinux
parentAdded ~sparc keyword wrt bug #104975. (diff)
downloadgentoo-2-00cebb424c14445802e042aef3a08e139e6b494a.tar.gz
gentoo-2-00cebb424c14445802e042aef3a08e139e6b494a.tar.bz2
gentoo-2-00cebb424c14445802e042aef3a08e139e6b494a.zip
update for libselinux with compat aliases.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog9
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-2.16-r23
-rw-r--r--dev-python/python-selinux/python-selinux-2.16-r2.ebuild30
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index 3af6aa419795..01e282a65d4d 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.32 2006/02/22 17:03:49 spb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.33 2006/02/27 01:25:29 pebenito Exp $
+
+*python-selinux-2.16-r2 (27 Feb 2006)
+
+ 27 Feb 2006; Chris PeBenito <pebenito@gentoo.org>
+ +python-selinux-2.16-r2.ebuild:
+ Update and require libselinux that has compatability aliases for selinux_aux
+ functions in the SWIG wrapper.
22 Feb 2006; Stephen Bennett <spb@gentoo.org>
python-selinux-2.16-r1.ebuild:
diff --git a/dev-python/python-selinux/files/digest-python-selinux-2.16-r2 b/dev-python/python-selinux/files/digest-python-selinux-2.16-r2
new file mode 100644
index 000000000000..a49f964e0aa3
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-2.16-r2
@@ -0,0 +1,3 @@
+MD5 cc1ee117f080c87a4c82548e179a5ac9 python-selinux-2.16-1.tar.bz2 11264
+RMD160 6b0a9ee26a3cd4018eeaaff1c7ec1e9dceb4f532 python-selinux-2.16-1.tar.bz2 11264
+SHA256 efddd98ac531bf4bb636a84504c952520b989b960ae11215c60d909cdd46a3de python-selinux-2.16-1.tar.bz2 11264
diff --git a/dev-python/python-selinux/python-selinux-2.16-r2.ebuild b/dev-python/python-selinux/python-selinux-2.16-r2.ebuild
new file mode 100644
index 000000000000..7f09225db06a
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-2.16-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-2.16-r2.ebuild,v 1.1 2006/02/27 01:25:30 pebenito Exp $
+
+inherit python
+
+DESCRIPTION="Extra python bindings for SELinux functions"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+LICENSE="GPL-2"
+SLOT="0"
+SRC_URI="mirror://gentoo/${P}-1.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ >=sys-libs/libselinux-1.28-r1"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cd ${S}
+ python_version
+ emake
+}
+
+src_install() {
+ python_version
+ make DESTDIR="${D}" install
+}