summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-02-18 21:07:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-02-18 21:07:45 +0000
commitaf829550242e88161bc1adc02bb352fd4930ffd3 (patch)
tree9f7f875127285fcf55bbed535a71a0944c65e328 /dev-python/python-mhash/python-mhash-1.3.ebuild
parent~amd64 (diff)
downloadgentoo-2-af829550242e88161bc1adc02bb352fd4930ffd3.tar.gz
gentoo-2-af829550242e88161bc1adc02bb352fd4930ffd3.tar.bz2
gentoo-2-af829550242e88161bc1adc02bb352fd4930ffd3.zip
Add in 1.3, 1.2 in stable x86.
(Portage version: 2.0.51.16)
Diffstat (limited to 'dev-python/python-mhash/python-mhash-1.3.ebuild')
-rw-r--r--dev-python/python-mhash/python-mhash-1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-mhash/python-mhash-1.3.ebuild b/dev-python/python-mhash/python-mhash-1.3.ebuild
new file mode 100644
index 000000000000..c49be0e7ce42
--- /dev/null
+++ b/dev-python/python-mhash/python-mhash-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-mhash/python-mhash-1.3.ebuild,v 1.1 2005/02/18 21:07:45 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="Python interface to libmhash"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+HOMEPAGE="http://mhash.sourceforge.net/"
+RDEPEND="virtual/python
+ app-crypt/mhash"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+IUSE=""
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ # fix a glitch for gcc3.3 compiling
+ sed '231s/$/\\/' -i ${S}/mhash.c
+ # fix typo in MHASH_WHIRLPOOL definition
+ sed -i -e 's/MHSH_WHIRLPOOL/MHASH_WHIRLPOOL/' ${S}/mhash.c
+ # fix typo in package setup.py definition
+ sed -i -e 's/VERSION = "1.2"/VERSION = "1.3"/' ${S}/setup.py
+}
+
+src_install() {
+ mydoc="AUTHORS LICENSE NEWS PKG-INFO README"
+ distutils_src_install
+}