summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-23 18:04:10 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-23 18:04:10 +0000
commite9f3ca3f3cf1da09b2dd1f1c762e696f190070a5 (patch)
tree659e326a0068207c57ee586985ae5b5deac30a92 /dev-python/python-exec
parentRespect CFLAGS (bug #458774 by RB). (diff)
downloadgentoo-2-e9f3ca3f3cf1da09b2dd1f1c762e696f190070a5.tar.gz
gentoo-2-e9f3ca3f3cf1da09b2dd1f1c762e696f190070a5.tar.bz2
gentoo-2-e9f3ca3f3cf1da09b2dd1f1c762e696f190070a5.zip
Version bump. Support symlinks, add a test suite.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/python-exec')
-rw-r--r--dev-python/python-exec/ChangeLog8
-rw-r--r--dev-python/python-exec/python-exec-0.3.ebuild36
-rw-r--r--dev-python/python-exec/python-exec-9999.ebuild4
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-python/python-exec/ChangeLog b/dev-python/python-exec/ChangeLog
index 768d20f1f3a5..00547444ae2b 100644
--- a/dev-python/python-exec/ChangeLog
+++ b/dev-python/python-exec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-exec
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.33 2013/02/20 09:53:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/ChangeLog,v 1.34 2013/02/23 18:04:10 mgorny Exp $
+
+*python-exec-0.3 (23 Feb 2013)
+
+ 23 Feb 2013; Michał Górny <mgorny@gentoo.org> +python-exec-0.3.ebuild,
+ python-exec-9999.ebuild:
+ Version bump. Support symlinks, add a test suite.
20 Feb 2013; Agostino Sarubbo <ago@gentoo.org> python-exec-0.2.ebuild:
Stable for s390, wrt bug #452934
diff --git a/dev-python/python-exec/python-exec-0.3.ebuild b/dev-python/python-exec/python-exec-0.3.ebuild
new file mode 100644
index 000000000000..3a540f02893f
--- /dev/null
+++ b/dev-python/python-exec/python-exec-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-0.3.ebuild,v 1.1 2013/02/23 18:04:10 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+append_impl() {
+ pyimpls+="${EPYTHON} "
+}
+
+src_configure() {
+ local pyimpls
+ python_foreach_impl append_impl
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-python/python-exec/python-exec-9999.ebuild b/dev-python/python-exec/python-exec-9999.ebuild
index ea6709fac162..cb90172b0c72 100644
--- a/dev-python/python-exec/python-exec-9999.ebuild
+++ b/dev-python/python-exec/python-exec-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-9999.ebuild,v 1.3 2013/01/19 10:21:12 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-9999.ebuild,v 1.4 2013/02/23 18:04:10 mgorny Exp $
EAPI=5
@@ -23,7 +23,7 @@ SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
#if LIVE