summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-21 19:17:59 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-21 19:17:59 +0000
commite1f28925b563aef092d04c5d8fc623aa12938efc (patch)
treebd92dcf05ad0393d3431152abc40f78e64f085de /dev-python/python-docs
parentDelete older ebuilds. (diff)
downloadgentoo-2-e1f28925b563aef092d04c5d8fc623aa12938efc.tar.gz
gentoo-2-e1f28925b563aef092d04c5d8fc623aa12938efc.tar.bz2
gentoo-2-e1f28925b563aef092d04c5d8fc623aa12938efc.zip
Version bumps.
(Portage version: 15835-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog10
-rw-r--r--dev-python/python-docs/python-docs-2.6.5.ebuild49
-rw-r--r--dev-python/python-docs/python-docs-3.1.2.ebuild49
3 files changed, 107 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index 3f22085e1ca4..7fb7be3fef62 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.139 2010/01/01 17:27:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.140 2010/03/21 19:17:59 arfrever Exp $
+
+*python-docs-3.1.2 (21 Mar 2010)
+*python-docs-2.6.5 (21 Mar 2010)
+
+ 21 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -python-docs-2.6.2-r1.ebuild, -python-docs-2.6.3.ebuild,
+ +python-docs-2.6.5.ebuild, +python-docs-3.1.2.ebuild:
+ Version bumps.
01 Jan 2010; Brent Baude <ranger@gentoo.org> python-docs-2.6.4.ebuild:
Marking python-docs-2.6.4 ppc64 for bug 295066
diff --git a/dev-python/python-docs/python-docs-2.6.5.ebuild b/dev-python/python-docs/python-docs-2.6.5.ebuild
new file mode 100644
index 000000000000..65868fa062e9
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.5.ebuild,v 1.1 2010/03/21 19:17:59 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20091230"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+eselect_python_update() {
+ local eselect_python_options
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
+
+ # Create python2 symlink.
+ eselect python update --python2 > /dev/null
+
+ eselect python update ${eselect_python_options}
+}
+
+pkg_postinst() {
+ eselect_python_update
+}
+
+pkg_postrm() {
+ eselect_python_update
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-3.1.2.ebuild b/dev-python/python-docs/python-docs-3.1.2.ebuild
new file mode 100644
index 000000000000..749c4a1e7057
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.2.ebuild,v 1.1 2010/03/21 19:17:59 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="3.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20091230"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+eselect_python_update() {
+ local eselect_python_options
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
+
+ # Create python3 symlink.
+ eselect python update --python3 > /dev/null
+
+ eselect python update ${eselect_python_options}
+}
+
+pkg_postinst() {
+ eselect_python_update
+}
+
+pkg_postrm() {
+ eselect_python_update
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}