summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-28 19:17:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-28 19:17:09 +0000
commita920dcb892b8712b57e44adc9429101d83b81c99 (patch)
tree3b1142c36b4001d55b33b50daf19a6fda5fc7063 /dev-python/python-docs
parentAdd ~alpha/~ia64/~sparc wrt #345605 (diff)
downloadgentoo-2-a920dcb892b8712b57e44adc9429101d83b81c99.tar.gz
gentoo-2-a920dcb892b8712b57e44adc9429101d83b81c99.tar.bz2
gentoo-2-a920dcb892b8712b57e44adc9429101d83b81c99.zip
Version bumps.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog11
-rw-r--r--dev-python/python-docs/python-docs-2.6.6.ebuild33
-rw-r--r--dev-python/python-docs/python-docs-2.7.1.ebuild33
-rw-r--r--dev-python/python-docs/python-docs-3.1.3.ebuild33
4 files changed, 109 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index b05f999c2416..887b3758177c 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.153 2010/10/07 12:18:36 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.154 2010/11/28 19:17:09 arfrever Exp $
+
+*python-docs-3.1.3 (28 Nov 2010)
+*python-docs-2.7.1 (28 Nov 2010)
+*python-docs-2.6.6 (28 Nov 2010)
+
+ 28 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +python-docs-2.6.6.ebuild, -python-docs-2.7.ebuild,
+ +python-docs-2.7.1.ebuild, +python-docs-3.1.3.ebuild:
+ Version bumps.
07 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
python-docs-2.6.5.ebuild:
diff --git a/dev-python/python-docs/python-docs-2.6.6.ebuild b/dev-python/python-docs/python-docs-2.6.6.ebuild
new file mode 100644
index 000000000000..aeb3469a71a9
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.6.6.ebuild,v 1.1 2010/11/28 19:17:09 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-2.7.1.ebuild b/dev-python/python-docs/python-docs-2.7.1.ebuild
new file mode 100644
index 000000000000..9981926f567b
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.7.1.ebuild,v 1.1 2010/11/28 19:17:09 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}
diff --git a/dev-python/python-docs/python-docs-3.1.3.ebuild b/dev-python/python-docs/python-docs-3.1.3.ebuild
new file mode 100644
index 000000000000..f69ad97a98c8
--- /dev/null
+++ b/dev-python/python-docs/python-docs-3.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-3.1.3.ebuild,v 1.1 2010/11/28 19:17:09 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="3.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+pkg_postrm() {
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}