summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 20:12:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 20:12:44 +0000
commit0442ffe2ac8c0e2eb695f048fa98a5171268a6ab (patch)
tree4f0e94da404bc7490b19b11b8d9449654c29b505 /dev-python/python-docs
parentRemoved KEYWORDS for which we now have stable ones in seamonkey-2. (diff)
downloadgentoo-2-0442ffe2ac8c0e2eb695f048fa98a5171268a6ab.tar.gz
gentoo-2-0442ffe2ac8c0e2eb695f048fa98a5171268a6ab.tar.bz2
gentoo-2-0442ffe2ac8c0e2eb695f048fa98a5171268a6ab.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/ChangeLog7
-rw-r--r--dev-python/python-docs/python-docs-2.7.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/python-docs/ChangeLog b/dev-python/python-docs/ChangeLog
index d2fa40c17f4e..1b1e489e41bf 100644
--- a/dev-python/python-docs/ChangeLog
+++ b/dev-python/python-docs/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-python/python-docs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.149 2010/07/04 20:08:46 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/ChangeLog,v 1.150 2010/07/04 20:12:44 arfrever Exp $
*python-docs-2.7 (04 Jul 2010)
04 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -python-docs-2.4.4.ebuild, -python-docs-2.5.4.ebuild,
+ +python-docs-2.7.ebuild, -python-docs-3.1.1.ebuild:
+ Version bump.
+
+ 04 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-docs-2.4.4-r1.ebuild, python-docs-2.5.4-r1.ebuild:
alpha/amd64/arm/hppa/ia64/m68k/ppc/ppc64/s390/sh/sparc/x86 stable.
diff --git a/dev-python/python-docs/python-docs-2.7.ebuild b/dev-python/python-docs/python-docs-2.7.ebuild
new file mode 100644
index 000000000000..62c8c08415a8
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.7.ebuild,v 1.1 2010/07/04 20:12:44 arfrever Exp $
+
+EAPI="3"
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="http://www.python.org/doc/"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+
+LICENSE="PSF-2.2"
+SLOT="2.7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-python-20091230"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/python-${PV}-docs-html"
+
+pkg_setup() {
+ if has_version "=dev-lang/python-2.7_pre*[doc]"; then
+ rm -f "${EROOT}etc/env.d/60python-docs-2.7"
+ fi
+}
+
+src_install() {
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html"
+
+ echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html/library\"" > "60python-docs-${SLOT}"
+ doenvd "60python-docs-${SLOT}"
+}
+
+eselect_python_update() {
+ local eselect_python_options
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
+
+ # Create python2 symlink.
+ eselect python update --python2 > /dev/null
+
+ eselect python update ${eselect_python_options}
+}
+
+pkg_postinst() {
+ eselect_python_update
+}
+
+pkg_postrm() {
+ eselect_python_update
+
+ if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
+ rm -f "${EROOT}etc/env.d/65python-docs"
+ fi
+}