summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-27 18:55:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-27 18:55:08 +0000
commit867fbb5ddd84617616a5c848cd6045a879769efb (patch)
tree45fe3fd8836f37c2017b4acdc376fb7f1ce0f51f /dev-python/python-bibtex/python-bibtex-1.2.4.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-867fbb5ddd84617616a5c848cd6045a879769efb.tar.gz
gentoo-2-867fbb5ddd84617616a5c848cd6045a879769efb.tar.bz2
gentoo-2-867fbb5ddd84617616a5c848cd6045a879769efb.zip
Set SUPPORT_PYTHON_ABIS. Fix tests (bug #264439).
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-bibtex/python-bibtex-1.2.4.ebuild')
-rw-r--r--dev-python/python-bibtex/python-bibtex-1.2.4.ebuild25
1 files changed, 21 insertions, 4 deletions
diff --git a/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild b/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild
index 50eb294774fe..40c2cb00d3a4 100644
--- a/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild
+++ b/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild,v 1.6 2008/08/12 11:45:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-bibtex/python-bibtex-1.2.4.ebuild,v 1.7 2010/03/27 18:55:08 arfrever Exp $
-inherit distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
DESCRIPTION="A Python extension to parse BibTeX files"
HOMEPAGE="http://pybliographer.org/"
@@ -17,7 +21,20 @@ RDEPEND=">=dev-libs/glib-2
>=app-text/recode-3.6-r1"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
+
+ # Disable tests during installation.
+ sed -e "/self.run_command ('check')/d" -i setup.py
+}
src_test() {
- "${python}" setup.py check || die "tests failed"
+ testing() {
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" check
+ }
+ python_execute_function testing
}