summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-04-04 18:30:58 +0000
committerMike Gilbert <floppym@gentoo.org>2013-04-04 18:30:58 +0000
commite64e5ca850b7e8523a5a9d051f4d328d6d317cc3 (patch)
tree0c2b69baee3b992b11167fb30f6626e2dd70ecb0 /dev-python/pytest
parentRe-order patch so the source files get patched first. (diff)
downloadgentoo-2-e64e5ca850b7e8523a5a9d051f4d328d6d317cc3.tar.gz
gentoo-2-e64e5ca850b7e8523a5a9d051f4d328d6d317cc3.tar.bz2
gentoo-2-e64e5ca850b7e8523a5a9d051f4d328d6d317cc3.zip
Drop unnecessary revbump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog5
-rw-r--r--dev-python/pytest/pytest-2.3.4-r1.ebuild51
2 files changed, 4 insertions, 52 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index a685579b3349..5cdb58142bd7 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.60 2013/04/04 18:24:34 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.61 2013/04/04 18:30:58 floppym Exp $
+
+ 04 Apr 2013; Mike Gilbert <floppym@gentoo.org> -pytest-2.3.4-r1.ebuild:
+ Drop unnecessary revbump.
04 Apr 2013; Mike Gilbert <floppym@gentoo.org>
files/pytest-2.3.4-unicode.patch, pytest-2.3.4-r1.ebuild:
diff --git a/dev-python/pytest/pytest-2.3.4-r1.ebuild b/dev-python/pytest/pytest-2.3.4-r1.ebuild
deleted file mode 100644
index 28fc05b2fc21..000000000000
--- a/dev-python/pytest/pytest-2.3.4-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4-r1.ebuild,v 1.2 2013/04/04 18:24:34 floppym Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_8,1_9,2_0} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="py.test: simple powerful testing with Python"
-HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc test"
-
-# When bumping, please check setup.py for the proper py version
-PY_VER="1.4.12"
-RDEPEND=">=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS=( CHANGELOG README.txt )
-
-python_prepare_all() {
- # Disable versioning of py.test script to avoid collision with
- # versioning performed by the eclass.
- sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
- grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
- distutils-r1_python_prepare_all
-
- epatch "${FILESDIR}"/${P}-unicode.patch
-}
-
-python_compile_all() {
- if use doc; then
- mkdir doc/en/.build || die
- emake -C doc/en html
- fi
-}
-
-python_test() {
- "${PYTHON}" pytest.py || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && dohtml -r doc/en/_build/html/
-}