summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 12:07:14 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 12:07:14 +0000
commit5364fb1c3eba6cf3ee693b9ac327d1a55737e793 (patch)
tree575990b34518f3ce5bab7a7fb10984135fb0e9b1 /dev-python/pyro
parentRemoved oldest stable version in the slot 4. (diff)
downloadgentoo-2-5364fb1c3eba6cf3ee693b9ac327d1a55737e793.tar.gz
gentoo-2-5364fb1c3eba6cf3ee693b9ac327d1a55737e793.tar.bz2
gentoo-2-5364fb1c3eba6cf3ee693b9ac327d1a55737e793.zip
Restored pyro-4.11, because this is the only candidate for the stabilization in the slot 4.
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog8
-rw-r--r--dev-python/pyro/pyro-4.11.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index ad31d3a6dd3d..3c06d805ef4a 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.66 2012/06/01 11:46:38 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.67 2012/06/01 12:07:14 aidecoe Exp $
+
+*pyro-4.11 (01 Jun 2012)
+
+ 01 Jun 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +pyro-4.11.ebuild:
+ Restored pyro-4.11, because this is the only candidate for the stabilization
+ in the slot 4.
01 Jun 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.4.ebuild:
Removed oldest stable version in the slot 4.
diff --git a/dev-python/pyro/pyro-4.11.ebuild b/dev-python/pyro/pyro-4.11.ebuild
new file mode 100644
index 000000000000..dd5c7877dcfa
--- /dev/null
+++ b/dev-python/pyro/pyro-4.11.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.11.ebuild,v 1.3 2012/06/01 12:07:14 aidecoe Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+
+inherit distutils
+
+MY_PN="Pyro4"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
+HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="!dev-python/pyro:0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="Pyro4"
+
+src_prepare() {
+ distutils_src_prepare
+
+ sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/testBCstart/_&/" \
+ -e "s/testDaemonPyroObj/_&/" \
+ -e "s/testLookupAndRegister/_&/" \
+ -e "s/testMulti/_&/" \
+ -e "s/testRefuseDottedNames/_&/" \
+ -e "s/testResolve/_&/" \
+ -i tests/PyroTests/test_naming.py
+ sed \
+ -e "s/testOwnloopBasics/_&/" \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py
+
+ sed \
+ -e "s/testServerConnections/_&/" \
+ -e "s/testServerParallelism/_&/" \
+ -i tests/PyroTests/test_server.py
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py
+}
+
+src_test() {
+ cd tests
+
+ testing() {
+ "$(PYTHON)" run_suite.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}