summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:10:37 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-09 22:10:37 +0000
commitcdaf137e341f8590dfd0c94802f83d32e7043f80 (patch)
tree81309649745f817bd3d6cfa47ac97deff2c8fcae /dev-python/pypam
parentppc64 stable wrt #325179 (diff)
downloadgentoo-2-cdaf137e341f8590dfd0c94802f83d32e7043f80.tar.gz
gentoo-2-cdaf137e341f8590dfd0c94802f83d32e7043f80.tar.bz2
gentoo-2-cdaf137e341f8590dfd0c94802f83d32e7043f80.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pypam')
-rw-r--r--dev-python/pypam/ChangeLog8
-rw-r--r--dev-python/pypam/pypam-0.5.0.ebuild41
2 files changed, 24 insertions, 25 deletions
diff --git a/dev-python/pypam/ChangeLog b/dev-python/pypam/ChangeLog
index aa93eaec86bf..0ae9a96795d5 100644
--- a/dev-python/pypam/ChangeLog
+++ b/dev-python/pypam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pypam
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypam/ChangeLog,v 1.4 2008/03/12 18:12:49 phreak Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypam/ChangeLog,v 1.5 2010/07/09 22:10:37 arfrever Exp $
+
+ 09 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pypam-0.5.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
12 Mar 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Marien Zwart (marienz, #107204) from metadata.xml.
diff --git a/dev-python/pypam/pypam-0.5.0.ebuild b/dev-python/pypam/pypam-0.5.0.ebuild
index 654b43fabe51..2b7c00c852ce 100644
--- a/dev-python/pypam/pypam-0.5.0.ebuild
+++ b/dev-python/pypam/pypam-0.5.0.ebuild
@@ -1,10 +1,16 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pypam/pypam-0.5.0.ebuild,v 1.2 2007/06/24 14:18:26 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pypam/pypam-0.5.0.ebuild,v 1.3 2010/07/09 22:10:37 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils eutils
-MY_P=${P/pypam/PyPAM}
+MY_PN="PyPAM"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="Python Bindings for PAM (Pluggable Authentication Modules)"
HOMEPAGE="http://www.pangalactic.org/PyPAM"
@@ -18,13 +24,14 @@ IUSE=""
DEPEND=">=sys-libs/pam-0.64"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
DOCS="AUTHORS examples/pamtest.py"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
+ distutils_src_prepare
# Fix a PyObject/PyMEM mixup.
epatch "${FILESDIR}/${P}-python-2.5.patch"
@@ -33,20 +40,8 @@ src_unpack() {
}
src_test() {
- "${python}" setup.py install --home="${T}/test" \
- || die "testinstall failed"
- PYTHONPATH="${T}/test/$(get_libdir)/python" "${python}" tests/PamTest.py \
- || die "tests failed"
-}
-
-pkg_postinst() {
- # HACK: we do not install any .py files, so there is no reason to
- # run python_mod_optimize here, like distutils_pkg_postrm does.
- :
-}
-
-pkg_postrm() {
- # HACK: we do not install any .py files, so there is no reason to
- # run python_mod_cleanup here, like distutils_pkg_postrm does.
- :
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" tests/PamTest.py
+ }
+ python_execute_function testing
}