summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-04 05:19:41 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-04 05:19:41 +0000
commit7efa5edaa5e09ff641f793e9193a6303946dc9de (patch)
treebe0915bb997e2272541cf35d355dac4a2586e015 /dev-python/pyml
parentVersion bump. (diff)
downloadgentoo-2-7efa5edaa5e09ff641f793e9193a6303946dc9de.tar.gz
gentoo-2-7efa5edaa5e09ff641f793e9193a6303946dc9de.tar.bz2
gentoo-2-7efa5edaa5e09ff641f793e9193a6303946dc9de.zip
revbump; conversion -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyml')
-rw-r--r--dev-python/pyml/ChangeLog11
-rw-r--r--dev-python/pyml/pyml-0.7.11.ebuild41
-rw-r--r--dev-python/pyml/pyml-0.7.12.ebuild41
-rw-r--r--dev-python/pyml/pyml-0.7.13.1.ebuild41
-rw-r--r--dev-python/pyml/pyml-0.7.13.2-r1.ebuild35
-rw-r--r--dev-python/pyml/pyml-0.7.13.2.ebuild41
6 files changed, 44 insertions, 166 deletions
diff --git a/dev-python/pyml/ChangeLog b/dev-python/pyml/ChangeLog
index 0463fa46714f..cd45f0d952c5 100644
--- a/dev-python/pyml/ChangeLog
+++ b/dev-python/pyml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/ChangeLog,v 1.5 2013/10/01 01:12:55 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/ChangeLog,v 1.6 2015/01/04 05:19:41 idella4 Exp $
+
+*pyml-0.7.13.2-r1 (04 Jan 2015)
+
+ 04 Jan 2015; Ian Delaney <idella4@gentoo.org> +pyml-0.7.13.2-r1.ebuild,
+ -pyml-0.7.11.ebuild, -pyml-0.7.12.ebuild, -pyml-0.7.13.1.ebuild,
+ -pyml-0.7.13.2.ebuild:
+ revbump; conversion -> distutils-r1, rm old
*pyml-0.7.13.2 (01 Oct 2013)
diff --git a/dev-python/pyml/pyml-0.7.11.ebuild b/dev-python/pyml/pyml-0.7.11.ebuild
deleted file mode 100644
index 188aaef337c9..000000000000
--- a/dev-python/pyml/pyml-0.7.11.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.11.ebuild,v 1.2 2012/12/07 17:00:50 bicatali Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-
-inherit distutils
-
-MYP=PyML-${PV}
-
-DESCRIPTION="Python machine learning package"
-HOMEPAGE="http://pyml.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MYP}"
-
-src_test() {
- cd data
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
-}
diff --git a/dev-python/pyml/pyml-0.7.12.ebuild b/dev-python/pyml/pyml-0.7.12.ebuild
deleted file mode 100644
index a60b2bad656e..000000000000
--- a/dev-python/pyml/pyml-0.7.12.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.12.ebuild,v 1.1 2013/09/02 04:43:55 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-
-inherit distutils
-
-MYP=PyML-${PV}
-
-DESCRIPTION="Python machine learning package"
-HOMEPAGE="http://pyml.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MYP}"
-
-src_test() {
- cd data
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
-}
diff --git a/dev-python/pyml/pyml-0.7.13.1.ebuild b/dev-python/pyml/pyml-0.7.13.1.ebuild
deleted file mode 100644
index a09528d790f3..000000000000
--- a/dev-python/pyml/pyml-0.7.13.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.13.1.ebuild,v 1.1 2013/09/18 06:27:45 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-
-inherit distutils
-
-MYP=PyML-${PV}
-
-DESCRIPTION="Python machine learning package"
-HOMEPAGE="http://pyml.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MYP}"
-
-src_test() {
- cd data
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
-}
diff --git a/dev-python/pyml/pyml-0.7.13.2-r1.ebuild b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
new file mode 100644
index 000000000000..55e022e18810
--- /dev/null
+++ b/dev-python/pyml/pyml-0.7.13.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.13.2-r1.ebuild,v 1.1 2015/01/04 05:19:41 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MYP=PyML-${PV}
+
+DESCRIPTION="Python machine learning package"
+HOMEPAGE="http://pyml.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MYP}"
+
+python_test() {
+ pushd data > /dev/null
+ "${PYTHON}" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || die "tests failed"
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
+}
diff --git a/dev-python/pyml/pyml-0.7.13.2.ebuild b/dev-python/pyml/pyml-0.7.13.2.ebuild
deleted file mode 100644
index a8ca15879b59..000000000000
--- a/dev-python/pyml/pyml-0.7.13.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyml/pyml-0.7.13.2.ebuild,v 1.1 2013/10/01 01:12:55 patrick Exp $
-
-EAPI=4
-
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-pypy-* *-jython"
-
-inherit distutils
-
-MYP=PyML-${PV}
-
-DESCRIPTION="Python machine learning package"
-HOMEPAGE="http://pyml.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-RDEPEND="dev-python/numpy"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S="${WORKDIR}/${MYP}"
-
-src_test() {
- cd data
- testing() {
- PYTHONPATH="$(ls -d ${S}/build-${PYTHON_ABI}/lib*)" \
- "$(PYTHON)" -c "from PyML.demo import pyml_test; pyml_test.test('svm')" || return 1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
- use doc && dodoc doc/tutorial.pdf && dohtml -r doc/autodoc/*
-}