summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2015-05-30 11:58:00 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2015-05-30 11:58:00 +0000
commit4076777c332609c396e12cf4ad83d63ab42c49a3 (patch)
tree023a4f6cece2886863505f32c39d01f17cd5015b /dev-python/pyjwt
parentForce the scanf configure test to select the POSIX version when cross-compili... (diff)
downloadgentoo-2-4076777c332609c396e12cf4ad83d63ab42c49a3.tar.gz
gentoo-2-4076777c332609c396e12cf4ad83d63ab42c49a3.tar.bz2
gentoo-2-4076777c332609c396e12cf4ad83d63ab42c49a3.zip
Bump to 1.3.0. Dropped arm keyword as dev-python/pytest-runner doesn't have it
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/ChangeLog7
-rw-r--r--dev-python/pyjwt/pyjwt-1.3.0.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/pyjwt/ChangeLog b/dev-python/pyjwt/ChangeLog
index 864ad0d53033..3d3336040a90 100644
--- a/dev-python/pyjwt/ChangeLog
+++ b/dev-python/pyjwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyjwt
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyjwt/ChangeLog,v 1.6 2015/04/08 08:05:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyjwt/ChangeLog,v 1.7 2015/05/30 11:58:00 maksbotan Exp $
+
+*pyjwt-1.3.0 (30 May 2015)
+
+ 30 May 2015; Maxim Koltsov <maksbotan@gentoo.org> +pyjwt-1.3.0.ebuild:
+ Bump to 1.3.0. Dropped arm keyword as dev-python/pytest-runner doesn't have it
08 Apr 2015; Michał Górny <mgorny@gentoo.org> pyjwt-0.2.1.ebuild:
Drop old Python implementations
diff --git a/dev-python/pyjwt/pyjwt-1.3.0.ebuild b/dev-python/pyjwt/pyjwt-1.3.0.ebuild
new file mode 100644
index 000000000000..b0de39dd7282
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-1.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyjwt/pyjwt-1.3.0.ebuild,v 1.1 2015/05/30 11:58:00 maksbotan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+MY_PN="PyJWT"
+
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="http://github.com/progrium/pyjwt https://pypi.python.org/pypi/PyJWT/"
+#SRC_URI="https://github.com/progrium/${P}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} \; || die "Cleaning __pycache__ failed"
+ find . -name '*.pyc' -exec rm -f {} \; || die "Cleaing *.pyc failed"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+ optfeature "flake8" dev-python/flake8
+
+ ewarn "flake8 feature requires 'flake8-import-order' and 'pep8-naming', which are not in portage yet"
+}