summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-10-13 17:05:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-10-13 17:05:10 +0000
commit11f1e7168c997cf3871ab9377fdf22b22277c50f (patch)
tree39dade4343bf31ff1306c6ef24b8322ee86c0a2b /dev-python/pygame
parentRemove built_with_use wrt #286719, thanks to Bartosz Szreder for patch. (diff)
downloadgentoo-2-11f1e7168c997cf3871ab9377fdf22b22277c50f.tar.gz
gentoo-2-11f1e7168c997cf3871ab9377fdf22b22277c50f.tar.bz2
gentoo-2-11f1e7168c997cf3871ab9377fdf22b22277c50f.zip
clean out old ebuilds
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog7
-rw-r--r--dev-python/pygame/files/pygame-1.8.1_icon_path.patch30
-rw-r--r--dev-python/pygame/pygame-1.7.1.ebuild52
-rw-r--r--dev-python/pygame/pygame-1.8.0.ebuild61
-rw-r--r--dev-python/pygame/pygame-1.8.1-r1.ebuild65
5 files changed, 6 insertions, 209 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 201abc5d6d13..85c9851dc2b6 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygame
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.66 2009/10/08 18:11:59 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.67 2009/10/13 17:05:09 mr_bones_ Exp $
+
+ 13 Oct 2009; Michael Sterrett <mr_bones_@gentoo.org> -pygame-1.7.1.ebuild,
+ -pygame-1.8.0.ebuild, -pygame-1.8.1-r1.ebuild,
+ -files/pygame-1.8.1_icon_path.patch:
+ clean out old ebuilds
08 Oct 2009; Raúl Porcel <armin76@gentoo.org> pygame-1.9.1.ebuild:
alpha/ia64/sparc stable wrt #287438
diff --git a/dev-python/pygame/files/pygame-1.8.1_icon_path.patch b/dev-python/pygame/files/pygame-1.8.1_icon_path.patch
deleted file mode 100644
index d2f1eb7385de..000000000000
--- a/dev-python/pygame/files/pygame-1.8.1_icon_path.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Patch: Patch to make tests works
-Added: 14 Jul 2009
-By: Jesus Rivero (Neurogeek)
-
-diff -uNr pygame-1.8.1release.orig/test/image_test.py pygame-1.8.1release/test/image_test.py
---- pygame-1.8.1release.orig/test/image_test.py 2009-07-14 19:20:38.000000000 -0430
-+++ pygame-1.8.1release/test/image_test.py 2009-07-14 19:34:11.000000000 -0430
-@@ -27,7 +27,7 @@
- def testLoadIcon(self):
- """ see if we can load the pygame icon.
- """
-- f = pygame.pkgdata.getResource("pygame_icon.bmp")
-+ f = pygame.pkgdata.getResource("../../../lib/pygame_icon.bmp")
- self.assertEqual(f.mode, "rb")
-
- surf = pygame.image.load_basic(f)
-
-diff -uNtr pygame-1.8.1release.orig/test/font_test.py pygame-1.8.1release.new/test/font_test.py
---- pygame-1.8.1release.orig/test/font_test.py 2009-07-14 19:20:38.000000000 -0430
-+++ pygame-1.8.1release.new/test/font_test.py 2009-07-14 20:53:02.000000000 -0430
-@@ -11,7 +11,7 @@
- """
- #print __file__
- pygame.font.init ()
-- f = pygame.font.Font(None, 20)
-+ f = pygame.font.Font("lib/freesansbold.ttf", 20)
- s = f.render("foo", True, [0, 0, 0], [255, 255, 255])
- s = f.render("xxx", True, [0, 0, 0], [255, 255, 255])
- s = f.render("", True, [0, 0, 0], [255, 255, 255])
-
diff --git a/dev-python/pygame/pygame-1.7.1.ebuild b/dev-python/pygame/pygame-1.7.1.ebuild
deleted file mode 100644
index e6e9dd2aed8b..000000000000
--- a/dev-python/pygame/pygame-1.7.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1.ebuild,v 1.13 2008/06/26 18:36:15 pythonhead Exp $
-
-inherit distutils
-
-MY_P="${PN}-${PV}release"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="http://www.pygame.org/ftp/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd"
-IUSE="doc"
-
-DEPEND="virtual/python
- >=media-libs/libsdl-1.2.5
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/sdl-image-1.2.2
- >=media-libs/sdl-mixer-1.2.4
- >=dev-python/numeric-22.0
- >=media-libs/smpeg-0.4.4-r1"
-
-pkg_setup() {
- if ! built_with_use media-libs/sdl-image png jpeg ; then
- eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
- USE-flags set."
- die "Missing USE-flag for media-libs/sdl-image"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # Search correct libdir for existing sdl libs
- sed -i -e "s:/lib:/$(get_libdir):" "${S}"/config_unix.py || die
-}
-
-src_install() {
- DOCS=WHATSNEW
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
- insinto /usr/share/doc/"${PF}"/examples
- doins "${S}"/examples/*
- insinto /usr/share/doc/"${PF}"/examples/data
- doins "${S}"/examples/data/*
- fi
-}
diff --git a/dev-python/pygame/pygame-1.8.0.ebuild b/dev-python/pygame/pygame-1.8.0.ebuild
deleted file mode 100644
index 715fa05bfd83..000000000000
--- a/dev-python/pygame/pygame-1.8.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.0.ebuild,v 1.2 2008/06/26 18:36:15 pythonhead Exp $
-
-inherit distutils multilib eutils
-
-DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=media-libs/libsdl-1.2.5
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/sdl-image-1.2.2
- >=media-libs/sdl-mixer-1.2.4
- dev-python/numpy
- >=media-libs/smpeg-0.4.4-r1"
-DEPEND="${DEPEND}
- dev-python/setuptools"
-
-S=${WORKDIR}/${P}release
-
-pkg_setup() {
- if ! built_with_use media-libs/libsdl X ; then
- eerror "Please re-emerge media-libs/libsdl with the X USE-flag set."
- die "Missing USE-flag for media-libs/libsdl"
- fi
- if ! built_with_use media-libs/sdl-image png jpeg ; then
- eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
- USE-flags set."
- die "Missing USE-flag for media-libs/sdl-image"
- fi
-}
-
-src_compile() {
- python config.py
- sed -i -e 's:X11R6/lib:lib64:g' Setup
-
- distutils_src_compile
-}
-
-src_install() {
- DOCS=WHATSNEW
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
-
- insinto /usr/share/doc/${PF}
- doins -r "${S}/examples"
- fi
-}
-
-src_test() {
- python_version
- PYTHONPATH="$(ls -d build/lib.*)" "${python}" run_tests.py || die "tests failed"
-}
diff --git a/dev-python/pygame/pygame-1.8.1-r1.ebuild b/dev-python/pygame/pygame-1.8.1-r1.ebuild
deleted file mode 100644
index 775a3943a099..000000000000
--- a/dev-python/pygame/pygame-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.1-r1.ebuild,v 1.2 2009/07/15 02:00:12 neurogeek Exp $
-
-EAPI="2"
-
-inherit distutils
-
-DESCRIPTION="python bindings to sdl and other libs that facilitate game production"
-HOMEPAGE="http://www.pygame.org/"
-SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc"
-
-RDEPEND=">=media-libs/libsdl-1.2.5[X]
- >=media-libs/sdl-ttf-2.0.6
- >=media-libs/sdl-image-1.2.2[png,jpeg]
- >=media-libs/sdl-mixer-1.2.4
- dev-python/numpy
- >=media-libs/smpeg-0.4.4-r1"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-S=${WORKDIR}/${P}release
-
-src_prepare(){
- epatch "${FILESDIR}/${P}_icon_path.patch"
-}
-
-src_compile() {
- python config.py
- sed -i -e 's:X11R6/lib:lib64:g' Setup
-
- distutils_src_compile
-}
-
-src_install() {
- DOCS="WHATSNEW"
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/*
-
- insinto "/usr/share/doc/${PF}"
- doins -r "${S}/examples"
- fi
-}
-
-src_test() {
- python_version
-
- #Skip tests that depend on DISPLAY being set. Bug #223055
- SKIP_TESTS="display_test image__save_gl_surface_test movie_test"
-
- for test_ in $SKIP_TESTS
- do
- einfo "Removing test: ${test_}"
- rm -rf "${S}/test/${test_}.py"
- done
-
- PYTHONPATH="$(ls -d build/lib.*)" "${python}" run_tests.py || die "tests failed"
-}