summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2013-04-27 19:10:14 +0000
committerPatrick McLean <chutzpah@gentoo.org>2013-04-27 19:10:14 +0000
commit8fe1c6bc69aebf5c8d44b8c9dcd3af5160cc1278 (patch)
tree58c4ac939fcd52d20146dfe6e42555421fdacd98 /dev-python/pyflakes
parentTrack subslot changes on icu. (diff)
downloadgentoo-2-8fe1c6bc69aebf5c8d44b8c9dcd3af5160cc1278.tar.gz
gentoo-2-8fe1c6bc69aebf5c8d44b8c9dcd3af5160cc1278.tar.bz2
gentoo-2-8fe1c6bc69aebf5c8d44b8c9dcd3af5160cc1278.zip
Version bump, port to distutils-r1. Clean out really old version.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-python/pyflakes')
-rw-r--r--dev-python/pyflakes/ChangeLog8
-rw-r--r--dev-python/pyflakes/pyflakes-0.4.0.ebuild23
-rw-r--r--dev-python/pyflakes/pyflakes-0.7.2.ebuild24
3 files changed, 31 insertions, 24 deletions
diff --git a/dev-python/pyflakes/ChangeLog b/dev-python/pyflakes/ChangeLog
index f9cada4f8d4a..07a94c031793 100644
--- a/dev-python/pyflakes/ChangeLog
+++ b/dev-python/pyflakes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyflakes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyflakes/ChangeLog,v 1.27 2013/02/21 03:17:57 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyflakes/ChangeLog,v 1.28 2013/04/27 19:10:14 chutzpah Exp $
+
+*pyflakes-0.7.2 (27 Apr 2013)
+
+ 27 Apr 2013; Patrick McLean <chutz@gentoo.org> +pyflakes-0.7.2.ebuild,
+ -pyflakes-0.4.0.ebuild:
+ Version bump, port to distutils-r1. Clean out really old version.
21 Feb 2013; Zac Medico <zmedico@gentoo.org> pyflakes-0.6.1.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-python/pyflakes/pyflakes-0.4.0.ebuild b/dev-python/pyflakes/pyflakes-0.4.0.ebuild
deleted file mode 100644
index d6b29ee7ed06..000000000000
--- a/dev-python/pyflakes/pyflakes-0.4.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyflakes/pyflakes-0.4.0.ebuild,v 1.7 2011/10/23 15:28:41 armin76 Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-DESCRIPTION="Passive checker for python programs."
-HOMEPAGE="http://divmod.org/trac/wiki/DivmodPyflakes http://pypi.python.org/pypi/pyflakes"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE=""
-
-DEPEND="test? ( dev-python/twisted )"
-RDEPEND=""
diff --git a/dev-python/pyflakes/pyflakes-0.7.2.ebuild b/dev-python/pyflakes/pyflakes-0.7.2.ebuild
new file mode 100644
index 000000000000..4063ac9c328f
--- /dev/null
+++ b/dev-python/pyflakes/pyflakes-0.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyflakes/pyflakes-0.7.2.ebuild,v 1.1 2013/04/27 19:10:14 chutzpah Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{2,3}})
+
+inherit distutils-r1
+
+DESCRIPTION="Passive checker for Python programs"
+HOMEPAGE="https://launchpad.net/pyflakes http://pypi.python.org/pypi/pyflakes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_test() {
+ esetup.py test --quiet
+}