summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 02:40:09 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 02:40:09 +0000
commit59e4f698abee77852d84cbdcb3e110c0b9d38c26 (patch)
tree73a9488b1df4e59834414db01e1f18fb18b8e95e /dev-python/pyenchant
parentAdd ~mips keyword - required by new cmake-2.8.3 (diff)
downloadgentoo-2-59e4f698abee77852d84cbdcb3e110c0b9d38c26.tar.gz
gentoo-2-59e4f698abee77852d84cbdcb3e110c0b9d38c26.tar.bz2
gentoo-2-59e4f698abee77852d84cbdcb3e110c0b9d38c26.zip
Version bump. Fixed tests with Python 3.2 (bug #338309).
(Portage version: 2.2.0_alpha9_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/ChangeLog8
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.5.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/pyenchant/ChangeLog b/dev-python/pyenchant/ChangeLog
index 55271669dc9b..7ec77cfcaf8d 100644
--- a/dev-python/pyenchant/ChangeLog
+++ b/dev-python/pyenchant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyenchant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.34 2010/12/13 20:16:52 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/ChangeLog,v 1.35 2010/12/18 02:40:09 arfrever Exp $
+
+*pyenchant-1.6.5 (18 Dec 2010)
+
+ 18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pyenchant-1.6.5.ebuild:
+ Version bump. Fixed tests with Python 3.2 (bug #338309).
*pyenchant-1.6.4 (13 Dec 2010)
diff --git a/dev-python/pyenchant/pyenchant-1.6.5.ebuild b/dev-python/pyenchant/pyenchant-1.6.5.ebuild
new file mode 100644
index 000000000000..b6926c86f178
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-1.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.5.ebuild,v 1.1 2010/12/18 02:40:09 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="http://pyenchant.sourceforge.net http://pypi.python.org/pypi/pyenchant"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/enchant-${PV%.*}
+ dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+DOCS="README.txt TODO.txt"
+PYTHON_MODNAME="enchant"
+
+src_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ distutils_src_test
+ fi
+}