summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 06:45:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 06:45:14 +0000
commita40a3248246336a0684b5ee3bc861d6432a88cb4 (patch)
tree5cec0a9ce07afa8e7d402b71e06fbfeaec5468ed /dev-python/pycxx
parentVersion bump (bug #289376). Set SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-a40a3248246336a0684b5ee3bc861d6432a88cb4.tar.gz
gentoo-2-a40a3248246336a0684b5ee3bc861d6432a88cb4.tar.bz2
gentoo-2-a40a3248246336a0684b5ee3bc861d6432a88cb4.zip
Version bump.
(Portage version: 14615-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog8
-rw-r--r--dev-python/pycxx/pycxx-6.1.1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index d1f10f0698c9..9363dc428e6d 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pycxx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.8 2009/10/11 10:26:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.9 2009/10/17 06:45:14 arfrever Exp $
+
+*pycxx-6.1.1 (17 Oct 2009)
+
+ 17 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pycxx-6.1.1.ebuild:
+ Version bump.
11 Oct 2009; Fabian Groffen <grobian@gentoo.org> pycxx-6.1.0.ebuild:
Merge from Prefix
diff --git a/dev-python/pycxx/pycxx-6.1.1.ebuild b/dev-python/pycxx/pycxx-6.1.1.ebuild
new file mode 100644
index 000000000000..8d80e32e8e7b
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.1.1.ebuild,v 1.1 2009/10/17 06:45:14 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc examples"
+
+PYTHON_MODNAME="CXX"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.1.0-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-6.1.0-python-3.patch"
+ epatch "${FILESDIR}/${PN}-6.1.0-C_compatible_headers.patch"
+
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r Doc/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples/python-2
+ dodoc Demo/Python2/* || die "dodoc failed"
+ docinto examples/python-3
+ dodoc Demo/Python3/* || die "dodoc failed"
+ fi
+}