summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-14 05:30:22 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-14 05:30:22 +0000
commit134469831d563db30529a9dfd25d245481f104f6 (patch)
tree843c54ed022216b7721ab9982983133ae75cb2ad /dev-python/pycxx
parentbump, rm old (diff)
downloadgentoo-2-134469831d563db30529a9dfd25d245481f104f6.tar.gz
gentoo-2-134469831d563db30529a9dfd25d245481f104f6.tar.bz2
gentoo-2-134469831d563db30529a9dfd25d245481f104f6.zip
bump; clean old impl, rm disused patches & old versions
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog13
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-python-3.2-Py_hash_t.patch27
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-python-3.2.patch232
-rw-r--r--dev-python/pycxx/files/pycxx-6.2.3-python-3.patch33
-rw-r--r--dev-python/pycxx/pycxx-6.2.3-r2.ebuild43
-rw-r--r--dev-python/pycxx/pycxx-6.2.3-r3.ebuild47
-rw-r--r--dev-python/pycxx/pycxx-6.2.4-r1.ebuild44
-rw-r--r--dev-python/pycxx/pycxx-6.2.4.ebuild40
-rw-r--r--dev-python/pycxx/pycxx-6.2.5.ebuild4
-rw-r--r--dev-python/pycxx/pycxx-6.2.6.ebuild37
10 files changed, 50 insertions, 470 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index 206fa80e389d..427195f419f0 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-python/pycxx
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.51 2014/08/14 23:58:14 idella4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.52 2015/01/14 05:30:22 idella4 Exp $
+
+*pycxx-6.2.6 (14 Jan 2015)
+
+ 14 Jan 2015; Ian Delaney <idella4@gentoo.org> +pycxx-6.2.6.ebuild,
+ -files/pycxx-6.2.3-python-3.2-Py_hash_t.patch,
+ -files/pycxx-6.2.3-python-3.2.patch, -files/pycxx-6.2.3-python-3.patch,
+ -pycxx-6.2.3-r2.ebuild, -pycxx-6.2.3-r3.ebuild, -pycxx-6.2.4-r1.ebuild,
+ -pycxx-6.2.4.ebuild, pycxx-6.2.5.ebuild:
+ bump; clean old impl, rm disused patches & old versions
14 Aug 2014; Ian Delaney <idella4@gentoo.org> pycxx-6.2.5.ebuild:
drop py2.6 pypy add py3_4
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-python-3.2-Py_hash_t.patch b/dev-python/pycxx/files/pycxx-6.2.3-python-3.2-Py_hash_t.patch
deleted file mode 100644
index c2bb0b78fdb4..000000000000
--- a/dev-python/pycxx/files/pycxx-6.2.3-python-3.2-Py_hash_t.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-https://sourceforge.net/tracker/?func=detail&aid=3464317&group_id=3180&atid=303180
---- Src/Python3/cxx_extensions.cxx
-+++ Src/Python3/cxx_extensions.cxx
-@@ -225,7 +225,11 @@
- static PyObject *rich_compare_handler( PyObject *, PyObject *, int );
- static PyObject *repr_handler( PyObject * );
- static PyObject *str_handler( PyObject * );
-+#if PY_VERSION_HEX >= 0x03020000
-+ static Py_hash_t hash_handler( PyObject * );
-+#else
- static long hash_handler( PyObject * );
-+#endif
- static PyObject *call_handler( PyObject *, PyObject *, PyObject * );
- static PyObject *iter_handler( PyObject * );
- static PyObject *iternext_handler( PyObject * );
-@@ -714,7 +718,11 @@
- }
- }
-
-+#if PY_VERSION_HEX >= 0x03020000
-+extern "C" Py_hash_t hash_handler( PyObject *self )
-+#else
- extern "C" long hash_handler( PyObject *self )
-+#endif
- {
- try
- {
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-python-3.2.patch b/dev-python/pycxx/files/pycxx-6.2.3-python-3.2.patch
deleted file mode 100644
index 84c02f4aee49..000000000000
--- a/dev-python/pycxx/files/pycxx-6.2.3-python-3.2.patch
+++ /dev/null
@@ -1,232 +0,0 @@
-http://cxx.svn.sourceforge.net/viewvc?view=revision&revision=266
-
---- CXX/Python3/ExtensionModule.hxx
-+++ CXX/Python3/ExtensionModule.hxx
-@@ -82,8 +82,6 @@
- extern "C" PyObject *method_varargs_call_handler( PyObject *_self_and_name_tuple, PyObject *_args );
- extern "C" PyObject *method_keyword_call_handler( PyObject *_self_and_name_tuple, PyObject *_args, PyObject *_keywords );
-
-- extern "C" void do_not_dealloc( void * );
--
- template<TEMPLATE_TYPENAME T>
- class ExtensionModule : public ExtensionModuleBase
- {
-@@ -134,11 +132,11 @@
- {
- MethodDefExt<T> *method_def = (*i).second;
-
-- static PyObject *self = PyCObject_FromVoidPtr( this, do_not_dealloc );
-+ static PyObject *self = PyCapsule_New( this, NULL, NULL );
-
- Tuple args( 2 );
- args[0] = Object( self );
-- args[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
-+ args[1] = Object( PyCapsule_New( method_def, NULL, NULL ) );
-
- PyObject *func = PyCFunction_New
- (
---- CXX/Python3/ExtensionOldType.hxx
-+++ CXX/Python3/ExtensionOldType.hxx
-@@ -178,7 +178,7 @@
- Tuple self( 2 );
-
- self[0] = Object( this );
-- self[1] = Object( PyCObject_FromVoidPtr( method_def, do_not_dealloc ) );
-+ self[1] = Object( PyCapsule_New( method_def, NULL, NULL ) );
-
- PyObject *func = PyCFunction_New( &method_def->ext_meth_def, self.ptr() );
-
-@@ -237,7 +237,7 @@
- T *self = static_cast<T *>( self_in_cobject );
-
- MethodDefExt<T> *meth_def = reinterpret_cast<MethodDefExt<T> *>(
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ) );
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ) );
-
- Object result;
-
-@@ -273,7 +273,7 @@
- PyObject *self_in_cobject = self_and_name_tuple[0].ptr();
- T *self = static_cast<T *>( self_in_cobject );
- MethodDefExt<T> *meth_def = reinterpret_cast<MethodDefExt<T> *>(
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ) );
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ) );
-
- Tuple args( _args );
-
-@@ -310,7 +310,7 @@
- PyObject *self_in_cobject = self_and_name_tuple[0].ptr();
- T *self = static_cast<T *>( self_in_cobject );
- MethodDefExt<T> *meth_def = reinterpret_cast<MethodDefExt<T> *>(
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ) );
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ) );
-
- Tuple args( _args );
-
---- CXX/Python3/IndirectPythonInterface.hxx
-+++ CXX/Python3/IndirectPythonInterface.hxx
-@@ -109,9 +109,6 @@
- PyTypeObject * _Method_Type();
- bool _Method_Check( PyObject *op );
-
--PyTypeObject * _CObject_Type();
--bool _CObject_Check( PyObject *op );
--
- PyTypeObject * _Complex_Type();
- bool _Complex_Check( PyObject *op );
-
---- Src/IndirectPythonInterface.cxx
-+++ Src/IndirectPythonInterface.cxx
-@@ -40,7 +40,6 @@
- namespace Py
- {
- bool _CFunction_Check( PyObject *op ) { return op->ob_type == _CFunction_Type(); }
--bool _CObject_Check( PyObject *op ) { return op->ob_type == _CObject_Type(); }
- bool _Complex_Check( PyObject *op ) { return op->ob_type == _Complex_Type(); }
- bool _Dict_Check( PyObject *op ) { return op->ob_type == _Dict_Type(); }
- bool _Float_Check( PyObject *op ) { return op->ob_type == _Float_Type(); }
-@@ -59,6 +58,7 @@
- #if PY_MAJOR_VERSION == 2
- bool _String_Check( PyObject *op ) { return op->ob_type == _String_Type(); }
- bool _Int_Check( PyObject *op ) { return op->ob_type == _Int_Type(); }
-+bool _CObject_Check( PyObject *op ) { return op->ob_type == _CObject_Type(); }
- #endif
- #if PY_MAJOR_VERSION >= 3
- bool _Bytes_Check( PyObject *op ) { return op->ob_type == _Bytes_Type(); }
-@@ -111,7 +111,6 @@
- static PyObject *ptr__PyFalse = NULL;
- static PyObject *ptr__PyTrue = NULL;
- static PyTypeObject *ptr__CFunction_Type = NULL;
--static PyTypeObject *ptr__CObject_Type = NULL;
- static PyTypeObject *ptr__Complex_Type = NULL;
- static PyTypeObject *ptr__Dict_Type = NULL;
- static PyTypeObject *ptr__Float_Type = NULL;
-@@ -129,6 +128,7 @@
- #if PY_MAJOR_VERSION == 2
- static PyTypeObject *ptr__Int_Type = NULL;
- static PyTypeObject *ptr__String_Type = NULL;
-+static PyTypeObject *ptr__CObject_Type = NULL;
- #endif
- #if PY_MAJOR_VERSION >= 3
- static PyTypeObject *ptr__Bytes_Type = NULL;
-@@ -284,7 +284,6 @@
- ptr__PyTrue = GetPyObject_As_PyObjectPointer( "_Py_TrueStruct" );
-
- ptr__CFunction_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyCFunction_Type" );
-- ptr__CObject_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyCObject_Type" );
- ptr__Complex_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyComplex_Type" );
- ptr__Dict_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyDict_Type" );
- ptr__Float_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyFloat_Type" );
-@@ -303,6 +302,7 @@
- #if PY_MAJOR_VERSION == 2
- ptr__String_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyString_Type" );
- ptr__Int_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyInt_Type" );
-+ ptr__CObject_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyCObject_Type" );
- #endif
- #if PY_MAJOR_VERSION >= 3
- ptr__Bytes_Type = GetPyTypeObject_As_PyTypeObjectPointer( "PyBytes_Type" );
-@@ -367,7 +367,6 @@
- PyObject *_True() { return ptr__PyTrue; }
-
- PyTypeObject *_CFunction_Type() { return ptr__CFunction_Type; }
--PyTypeObject *_CObject_Type() { return ptr__CObject_Type; }
- PyTypeObject *_Complex_Type() { return ptr__Complex_Type; }
- PyTypeObject *_Dict_Type() { return ptr__Dict_Type; }
- PyTypeObject *_Float_Type() { return ptr__Float_Type; }
-@@ -386,6 +385,7 @@
- #if PY_MAJOR_VERSION == 2
- PyTypeObject *_String_Type() { return ptr__String_Type; }
- PyTypeObject *_Int_Type() { return ptr__Int_Type; }
-+PyTypeObject *_CObject_Type() { return ptr__CObject_Type; }
- #endif
- #if PY_MAJOR_VERSION >= 3
- PyTypeObject *_Bytes_Type() { return ptr__Bytes_Type; }
-@@ -506,7 +506,6 @@
- PyObject *_True() { return Py_True; }
-
- PyTypeObject *_CFunction_Type() { return &PyCFunction_Type; }
--PyTypeObject *_CObject_Type() { return &PyCObject_Type; }
- PyTypeObject *_Complex_Type() { return &PyComplex_Type; }
- PyTypeObject *_Dict_Type() { return &PyDict_Type; }
- PyTypeObject *_Float_Type() { return &PyFloat_Type; }
-@@ -525,6 +524,7 @@
- #if PY_MAJOR_VERSION == 2
- PyTypeObject *_String_Type() { return &PyString_Type; }
- PyTypeObject *_Int_Type() { return &PyInt_Type; }
-+PyTypeObject *_CObject_Type() { return &PyCObject_Type; }
- #endif
- #if PY_MAJOR_VERSION >= 3
- PyTypeObject *_Bytes_Type() { return &PyBytes_Type; }
---- Src/Python3/cxx_extensions.cxx
-+++ Src/Python3/cxx_extensions.cxx
-@@ -1471,13 +1471,13 @@
- Tuple self_and_name_tuple( _self_and_name_tuple );
-
- PyObject *self_in_cobject = self_and_name_tuple[0].ptr();
-- void *self_as_void = PyCObject_AsVoidPtr( self_in_cobject );
-+ void *self_as_void = PyCapsule_GetPointer( self_in_cobject, NULL );
- if( self_as_void == NULL )
- return NULL;
-
- ExtensionModuleBase *self = static_cast<ExtensionModuleBase *>( self_as_void );
-
-- Object result( self->invoke_method_noargs( PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ) ) );
-+ Object result( self->invoke_method_noargs( PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ) ) );
-
- return new_reference_to( result.ptr() );
- }
-@@ -1494,7 +1494,7 @@
- Tuple self_and_name_tuple( _self_and_name_tuple );
-
- PyObject *self_in_cobject = self_and_name_tuple[0].ptr();
-- void *self_as_void = PyCObject_AsVoidPtr( self_in_cobject );
-+ void *self_as_void = PyCapsule_GetPointer( self_in_cobject, NULL );
- if( self_as_void == NULL )
- return NULL;
-
-@@ -1504,7 +1504,7 @@
- (
- self->invoke_method_varargs
- (
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ),
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ),
- args
- )
- );
-@@ -1524,7 +1524,7 @@
- Tuple self_and_name_tuple( _self_and_name_tuple );
-
- PyObject *self_in_cobject = self_and_name_tuple[0].ptr();
-- void *self_as_void = PyCObject_AsVoidPtr( self_in_cobject );
-+ void *self_as_void = PyCapsule_GetPointer( self_in_cobject, NULL );
- if( self_as_void == NULL )
- return NULL;
-
-@@ -1540,7 +1540,7 @@
- (
- self->invoke_method_keyword
- (
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ),
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ),
- args,
- keywords
- )
-@@ -1556,7 +1556,7 @@
- (
- self->invoke_method_keyword
- (
-- PyCObject_AsVoidPtr( self_and_name_tuple[1].ptr() ),
-+ PyCapsule_GetPointer( self_and_name_tuple[1].ptr(), NULL ),
- args,
- keywords
- )
-@@ -1571,9 +1571,6 @@
- }
- }
-
--extern "C" void do_not_dealloc( void * )
--{}
--
-
- //--------------------------------------------------------------------------------
- //
diff --git a/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch b/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch
deleted file mode 100644
index c5d6ac0f4d0f..000000000000
--- a/dev-python/pycxx/files/pycxx-6.2.3-python-3.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- Lib/__init__.py
-+++ Lib/__init__.py
-@@ -34,8 +34,8 @@
- # DAMAGE.
- #
- #-----------------------------------------------------------------------------
--print """CXX is installed.
-+print("""CXX is installed.
- The support files you need are in the PYTHON/etc/CXX directory.
- The include files are in the distutils include path already.
- Just refer to them as "CXX/CXX_Objects.h", etc.
--"""
-+""")
---- setup.py
-+++ setup.py
-@@ -12,13 +12,13 @@
- class my_install (install):
-
- def finalize_options (self):
-- if not self.install_data or (len(self.install_data) < 8) :
-- self.install_data = "$base/share/python$py_version_short"
-+ if not self.install_data or (len(self.install_data) < 8) :
-+ self.install_data = "$base/share/python$py_version_short"
- install.finalize_options (self)
-
- def run (self):
-- self.distribution.data_files = [("CXX", sources)]
-- self.distribution.headers = headers
-+ self.distribution.data_files = [("CXX", sources)]
-+ self.distribution.headers = headers
- install.run (self)
-
-
diff --git a/dev-python/pycxx/pycxx-6.2.3-r2.ebuild b/dev-python/pycxx/pycxx-6.2.3-r2.ebuild
deleted file mode 100644
index 3a9a33b2ce73..000000000000
--- a/dev-python/pycxx/pycxx-6.2.3-r2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.3-r2.ebuild,v 1.5 2011/11/29 11:04:25 naota Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils distutils
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-PYTHON_MODNAME="CXX"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python-3.patch"
- epatch "${FILESDIR}/${P}-installation.patch"
- epatch "${FILESDIR}/${P}-python-3.2.patch"
-
- sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r Doc/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples/python-2
- dodoc Demo/Python2/* || die "dodoc failed"
- docinto examples/python-3
- dodoc Demo/Python3/* || die "dodoc failed"
- fi
-}
diff --git a/dev-python/pycxx/pycxx-6.2.3-r3.ebuild b/dev-python/pycxx/pycxx-6.2.3-r3.ebuild
deleted file mode 100644
index 3308d41beb7e..000000000000
--- a/dev-python/pycxx/pycxx-6.2.3-r3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.3-r3.ebuild,v 1.5 2012/04/04 21:14:26 jdhore Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils distutils
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-PYTHON_MODNAME="CXX"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-python-3.patch"
- epatch "${FILESDIR}/${P}-installation.patch"
- epatch "${FILESDIR}/${P}-python-3.2.patch"
-
- # Bug 369329.
- # https://sourceforge.net/tracker/?func=detail&aid=3464317&group_id=3180&atid=303180
- epatch "${FILESDIR}/${P}-python-3.2-Py_hash_t.patch"
-
- sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r Doc/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples/python-2
- dodoc Demo/Python2/* || die "dodoc failed"
- docinto examples/python-3
- dodoc Demo/Python3/* || die "dodoc failed"
- fi
-}
diff --git a/dev-python/pycxx/pycxx-6.2.4-r1.ebuild b/dev-python/pycxx/pycxx-6.2.4-r1.ebuild
deleted file mode 100644
index 0ed009904fea..000000000000
--- a/dev-python/pycxx/pycxx-6.2.4-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.4-r1.ebuild,v 1.4 2012/06/08 11:34:54 phajdan.jr Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils distutils
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-PYTHON_MODNAME="CXX"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-6.2.3-python-3.patch"
- epatch "${FILESDIR}/${PN}-6.2.3-installation.patch"
-
- # Without this, pysvn fails.
- # CXX/Python2/Config.hxx: No such file or directory
- sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r Doc/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples/python-2
- dodoc Demo/Python2/* || die "dodoc failed"
- docinto examples/python-3
- dodoc Demo/Python3/* || die "dodoc failed"
- fi
-}
diff --git a/dev-python/pycxx/pycxx-6.2.4.ebuild b/dev-python/pycxx/pycxx-6.2.4.ebuild
deleted file mode 100644
index ef8eb74124db..000000000000
--- a/dev-python/pycxx/pycxx-6.2.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.4.ebuild,v 1.1 2012/03/29 10:52:46 djc Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
-
-inherit eutils distutils
-
-DESCRIPTION="Set of facilities to extend Python with C++"
-HOMEPAGE="http://cxx.sourceforge.net"
-SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="doc examples"
-
-PYTHON_MODNAME="CXX"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-6.2.3-python-3.patch"
- epatch "${FILESDIR}/${PN}-6.2.3-installation.patch"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r Doc/ || die "dohtml failed"
- fi
-
- if use examples; then
- docinto examples/python-2
- dodoc Demo/Python2/* || die "dodoc failed"
- docinto examples/python-3
- dodoc Demo/Python3/* || die "dodoc failed"
- fi
-}
diff --git a/dev-python/pycxx/pycxx-6.2.5.ebuild b/dev-python/pycxx/pycxx-6.2.5.ebuild
index 204a65b6105b..87eaa3bd9ec3 100644
--- a/dev-python/pycxx/pycxx-6.2.5.ebuild
+++ b/dev-python/pycxx/pycxx-6.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.5.ebuild,v 1.6 2014/08/14 23:58:14 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.5.ebuild,v 1.7 2015/01/14 05:30:22 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
diff --git a/dev-python/pycxx/pycxx-6.2.6.ebuild b/dev-python/pycxx/pycxx-6.2.6.ebuild
new file mode 100644
index 000000000000..4f736bdb3f1a
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.6.ebuild,v 1.1 2015/01/14 05:30:22 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # CXX/Python2/Config.hxx: No such file or directory
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+
+ # Remove python2 print statement
+ echo > Lib/__init__.py || die
+
+ local PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-installation.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/. )
+ use examples && local EXAMPLES=( Demo/Python{2,3}/. )
+ distutils-r1_python_install_all
+}