summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2011-01-27 01:20:14 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2011-01-27 01:20:14 +0000
commit327688a187e754d03241899c842dce4ae524f11b (patch)
treebfd37e1ab30c120fcf3eb87ece2f2389972587eb /dev-python/pycups
parentVersion bump (diff)
downloadgentoo-2-327688a187e754d03241899c842dce4ae524f11b.tar.gz
gentoo-2-327688a187e754d03241899c842dce4ae524f11b.tar.bz2
gentoo-2-327688a187e754d03241899c842dce4ae524f11b.zip
Version bump
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycups')
-rw-r--r--dev-python/pycups/ChangeLog9
-rw-r--r--dev-python/pycups/pycups-1.9.53.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/pycups/ChangeLog b/dev-python/pycups/ChangeLog
index a70e21b79739..36e9440ee0d6 100644
--- a/dev-python/pycups/ChangeLog
+++ b/dev-python/pycups/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycups
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.26 2010/11/06 18:46:59 halcy0n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/ChangeLog,v 1.27 2011/01/27 01:20:14 reavertm Exp $
+
+*pycups-1.9.53 (27 Jan 2011)
+
+ 27 Jan 2011; Maciej Mrozowski <reavertm@gentoo.org> +pycups-1.9.53.ebuild:
+ Version bump
06 Nov 2010; Mark Loeser <halcy0n@gentoo.org> pycups-1.9.46.ebuild:
Revert to ~ppc64; bug #322849
diff --git a/dev-python/pycups/pycups-1.9.53.ebuild b/dev-python/pycups/pycups-1.9.53.ebuild
new file mode 100644
index 000000000000..54de57328bf2
--- /dev/null
+++ b/dev-python/pycups/pycups-1.9.53.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycups/pycups-1.9.53.ebuild,v 1.1 2011/01/27 01:20:14 reavertm Exp $
+
+EAPI="2"
+
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+inherit distutils flag-o-matic
+
+DESCRIPTION="Python bindings for the CUPS API"
+HOMEPAGE="http://cyberelk.net/tim/data/pycups/"
+SRC_URI="http://cyberelk.net/tim/data/pycups/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="
+ >=net-print/cups-1.4.4
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/epydoc )
+"
+
+src_compile() {
+ append-cflags -DVERSION=\\\"${PV}\\\"
+ distutils_src_compile
+
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r html/ || die "installing html docs failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/"${P}"
+ doins -r examples/ || die "installing examples failed"
+ fi
+}