summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-17 08:50:08 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-17 08:50:08 +0000
commit569c466891e001aa8d79e2f6743be331fb667952 (patch)
tree9f10ccf6e5da948cd1b70904cb88169c4c7fda62 /dev-python/pyclamav
parentStable for HPPA (bug #538126). (diff)
downloadgentoo-2-569c466891e001aa8d79e2f6743be331fb667952.tar.gz
gentoo-2-569c466891e001aa8d79e2f6743be331fb667952.tar.bz2
gentoo-2-569c466891e001aa8d79e2f6743be331fb667952.zip
revbump; convert -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyclamav')
-rw-r--r--dev-python/pyclamav/ChangeLog10
-rw-r--r--dev-python/pyclamav/pyclamav-0.4.1-r2.ebuild35
2 files changed, 42 insertions, 3 deletions
diff --git a/dev-python/pyclamav/ChangeLog b/dev-python/pyclamav/ChangeLog
index 1864f58a304d..10f4e603a55f 100644
--- a/dev-python/pyclamav/ChangeLog
+++ b/dev-python/pyclamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyclamav
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclamav/ChangeLog,v 1.26 2012/03/13 02:54:16 floppym Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclamav/ChangeLog,v 1.27 2015/02/17 08:50:08 idella4 Exp $
+
+*pyclamav-0.4.1-r2 (17 Feb 2015)
+
+ 17 Feb 2015; Ian Delaney <idella4@gentoo.org> +pyclamav-0.4.1-r2.ebuild:
+ revbump; convert -> distutils-r1, rm old
13 Mar 2012; Mike Gilbert <floppym@gentoo.org> pyclamav-0.4.1-r1.ebuild:
Restrict Python 3. Patch by Arfrever.
@@ -101,4 +106,3 @@
05 Jun 2004; Bryan Østergaard <kloeri@gentoo.org> +pyclamav-0.1.ebuild:
Initial commit, bug #52089.
-
diff --git a/dev-python/pyclamav/pyclamav-0.4.1-r2.ebuild b/dev-python/pyclamav/pyclamav-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..f7b76a45a99c
--- /dev/null
+++ b/dev-python/pyclamav/pyclamav-0.4.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyclamav/pyclamav-0.4.1-r2.ebuild,v 1.1 2015/02/17 08:50:08 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding for libclamav"
+HOMEPAGE="http://xael.org/norman/python/pyclamav/ http://pypi.python.org/pypi/pyclamav"
+SRC_URI="http://xael.org/norman/python/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=app-antivirus/clamav-0.90"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-clamav-0.95.patch )
+DOCS=( README.txt example.py )
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/doc/${PF}
+ doins example.py
+}
+
+pkg_postinst() {
+ elog "an example called example.py has been installed into /usr/share/doc/${PF}"
+}