summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-26 19:09:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-26 19:09:17 +0000
commiteb5eaa41f3c56c949fa1bb309f005f95511fe197 (patch)
tree333ba13148a2a357d234a6f88e0d5d5da62857b6 /dev-python/pyamg
parentEnable optional support for graphite via graphite2 package. (diff)
downloadgentoo-2-eb5eaa41f3c56c949fa1bb309f005f95511fe197.tar.gz
gentoo-2-eb5eaa41f3c56c949fa1bb309f005f95511fe197.tar.bz2
gentoo-2-eb5eaa41f3c56c949fa1bb309f005f95511fe197.zip
Initial import to the main tree. Fixed tests, added doc.
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyamg')
-rw-r--r--dev-python/pyamg/ChangeLog19
-rw-r--r--dev-python/pyamg/metadata.xml21
-rw-r--r--dev-python/pyamg/pyamg-2.0.0.ebuild53
3 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/pyamg/ChangeLog b/dev-python/pyamg/ChangeLog
new file mode 100644
index 000000000000..eb6fd27fb2e2
--- /dev/null
+++ b/dev-python/pyamg/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for dev-python/pyamg
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/ChangeLog,v 1.1 2011/07/26 19:09:17 bicatali Exp $
+
+ 26 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +pyamg-2.0.0.ebuild,
+ +metadata.xml:
+ Initial import to the main tree. Fixed tests, added doc.
+
+*pyamg-2.0.0 (21 Mar 2011)
+
+ 21 Mar 2011; Nico Schlömer <nico.schloemer@gmail.com>
+ +pyamg-2.0.0.ebuild:
+ bumped to 2.0.0
+
+*pyamg-1.0.0 (13 Dec 2010)
+
+ 13 December 2010; Nico Schlömer <nico.schloemer@gmail.com>
+ +metadata.xml, +pyamg-1.0.0.ebuild:
+ Initial import.
diff --git a/dev-python/pyamg/metadata.xml b/dev-python/pyamg/metadata.xml
new file mode 100644
index 000000000000..26e721d94308
--- /dev/null
+++ b/dev-python/pyamg/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ AMG is a multilevel technique for solving large-scale linear systems
+ with optimal or near-optimal efficiency. Unlike geometric multigrid,
+ AMG requires little or no geometric information about the underlying
+ problem and develops a sequence of coarser grids directly from the
+ input matrix. This feature is especially important for problems
+ discretized on unstructured meshes and irregular grids.
+ PyAMG features implementations of:
+ * Ruge-Stuben (RS) or Classical AMG
+ * AMG based on Smoothed Aggregation (SA)
+ and experimental support for:
+ * Adaptive Smoothed Aggregation (αSA)
+ * Compatible Relaxation (CR)
+ The predominant portion of PyAMG is written in Python with a smaller
+ amount of supporting C++ code for performance critical operations.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyamg/pyamg-2.0.0.ebuild b/dev-python/pyamg/pyamg-2.0.0.ebuild
new file mode 100644
index 000000000000..efd0125ca1c9
--- /dev/null
+++ b/dev-python/pyamg/pyamg-2.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyamg/pyamg-2.0.0.ebuild,v 1.1 2011/07/26 19:09:17 bicatali Exp $
+
+EAPI=3
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="http://code.google.com/p/pyamg/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc test"
+
+RESTRICT="test" # quite buggy
+
+RDEPEND="sci-libs/scipy"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/nose )"
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ cd "${S}/Docs"
+ PYTHONPATH=$(ls -d "${S}"/build-$(PYTHON -f --ABI)/lib*) emake html
+ fi
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py \
+ build -b "build-${PYTHON_ABI}" \
+ install --home="${S}/test-${PYTHON_ABI}"
+ pushd "${S}/test-${PYTHON_ABI}/lib/python" > /dev/null
+ PYTHONPATH=. "$(PYTHON)" -c "import pyamg; pyamg.test()" 2>&1 | tee test.log
+ grep -Eq "^(ERROR|FAIL):" test.log && return 1
+ popd > /dev/null
+ rm -fr test-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ use doc && dohtml -r Docs/build/html/*
+}