summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-14 05:00:01 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-14 05:00:01 +0000
commitf1d7c7fd29397f7b52eb763d79c100647adb7347 (patch)
treecb1a0471c1f34863066ecdc56dbfcdb1fc79f393 /dev-python/py
parentEAPI=5; fix underlinking (bug #496924) (diff)
downloadgentoo-2-f1d7c7fd29397f7b52eb763d79c100647adb7347.tar.gz
gentoo-2-f1d7c7fd29397f7b52eb763d79c100647adb7347.tar.bz2
gentoo-2-f1d7c7fd29397f7b52eb763d79c100647adb7347.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/ChangeLog7
-rw-r--r--dev-python/py/py-1.4.23.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index 74b251b15d01..88eee39944a1 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.175 2014/08/07 09:03:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.176 2014/08/14 05:00:01 idella4 Exp $
+
+*py-1.4.23 (14 Aug 2014)
+
+ 14 Aug 2014; Ian Delaney <idella4@gentoo.org> +py-1.4.23.ebuild:
+ bump
07 Aug 2014; Jeroen Roovers <jer@gentoo.org> py-1.4.20.ebuild:
Stable for HPPA (bug #506042).
diff --git a/dev-python/py/py-1.4.23.ebuild b/dev-python/py/py-1.4.23.ebuild
new file mode 100644
index 000000000000..506a0504c2c9
--- /dev/null
+++ b/dev-python/py/py-1.4.23.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.4.23.ebuild,v 1.1 2014/08/14 05:00:01 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.readthedocs.org/ http://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test || die "testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}