summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-09 02:08:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-09 02:08:30 +0000
commit8d14f2c92cadca251e721393b8edf330f8de8c5c (patch)
tree77d27a6389b3fcd6716d5d6d28573a3d1dd33996 /dev-python/py
parentTests from tests/test_cookie_only.py now pass. (diff)
downloadgentoo-2-8d14f2c92cadca251e721393b8edf330f8de8c5c.tar.gz
gentoo-2-8d14f2c92cadca251e721393b8edf330f8de8c5c.tar.bz2
gentoo-2-8d14f2c92cadca251e721393b8edf330f8de8c5c.zip
Version bump. Fixed tests with Python 3.2 (bug #351060).
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/py')
-rw-r--r--dev-python/py/ChangeLog8
-rw-r--r--dev-python/py/py-1.4.1.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/py/ChangeLog b/dev-python/py/ChangeLog
index e1048c6b1552..6fc0c3af37a2 100644
--- a/dev-python/py/ChangeLog
+++ b/dev-python/py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/py
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.76 2011/01/30 18:25:27 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/ChangeLog,v 1.77 2011/02/09 02:08:30 arfrever Exp $
+
+*py-1.4.1 (09 Feb 2011)
+
+ 09 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +py-1.4.1.ebuild:
+ Version bump. Fixed tests with Python 3.2 (bug #351060).
30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-py-1.3.4.ebuild:
diff --git a/dev-python/py/py-1.4.1.ebuild b/dev-python/py/py-1.4.1.ebuild
new file mode 100644
index 000000000000..5b859cb86e4e
--- /dev/null
+++ b/dev-python/py/py-1.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/py/py-1.4.1.ebuild,v 1.1 2011/02/09 02:08:30 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="py.test"
+
+inherit distutils
+
+DESCRIPTION="library with cross-python path, ini-parsing, io, code, log facilities"
+HOMEPAGE="http://pylib.org/ http://pypi.python.org/pypi/py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools
+ test? ( >=dev-python/pytest-2.0.0 )"
+RDEPEND=""
+
+DOCS="CHANGELOG README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable failing tests.
+ rm -f testing/path/test_svnauth.py
+ rm -f testing/path/test_svnurl.py
+ rm -f testing/path/test_svnwc.py
+}