summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-14 07:43:04 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-14 07:43:04 +0000
commitdb0cde680fa4d8f82571f8e43e36d8a32d45dedf (patch)
treed03181a28a95ac1e922627f22c9146a1b43d7992 /dev-python/psycopg/files
parentVersion bump. (diff)
downloadgentoo-2-db0cde680fa4d8f82571f8e43e36d8a32d45dedf.tar.gz
gentoo-2-db0cde680fa4d8f82571f8e43e36d8a32d45dedf.tar.bz2
gentoo-2-db0cde680fa4d8f82571f8e43e36d8a32d45dedf.zip
Version bump psycopg to 2.4.2 (bug 379601).
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg/files')
-rw-r--r--dev-python/psycopg/files/psycopg-2.4.2-begin-segfault.patch34
-rw-r--r--dev-python/psycopg/files/psycopg-2.4.2-setup.py.patch13
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/psycopg/files/psycopg-2.4.2-begin-segfault.patch b/dev-python/psycopg/files/psycopg-2.4.2-begin-segfault.patch
new file mode 100644
index 000000000000..cbf2278d0bfa
--- /dev/null
+++ b/dev-python/psycopg/files/psycopg-2.4.2-begin-segfault.patch
@@ -0,0 +1,34 @@
+X-Git-Url: https://dndg.it/cgi-bin/gitweb.cgi?p=public%2Fpsycopg2.git;a=blobdiff_plain;f=psycopg%2Fpqpath.c;h=1f0d5da95bd88aa4d5468874047e4b0139ffadd3;hp=cee5ce4c9c053981710959ca28b7e68702c44a97;hb=de6f2ac387231fcd57c05031c82471ea57255e2b;hpb=d9fce1f837151e6eadfd8ca761ef328a721198bd
+
+diff --git a/psycopg/pqpath.c b/psycopg/pqpath.c
+index cee5ce4..1f0d5da 100644
+--- a/psycopg/pqpath.c
++++ b/psycopg/pqpath.c
+@@ -344,11 +344,13 @@ pq_execute_command_locked(connectionObject *conn, const char *query,
+ }
+ if (*pgres == NULL) {
+ Dprintf("pq_execute_command_locked: PQexec returned NULL");
++ PyEval_RestoreThread(*tstate);
+ if (!PyErr_Occurred()) {
+ const char *msg;
+ msg = PQerrorMessage(conn->pgconn);
+ if (msg && *msg) { *error = strdup(msg); }
+ }
++ *tstate = PyEval_SaveThread();
+ goto cleanup;
+ }
+
+@@ -635,11 +637,13 @@ pq_get_guc_locked(
+
+ if (*pgres == NULL) {
+ Dprintf("pq_get_guc_locked: PQexec returned NULL");
++ PyEval_RestoreThread(*tstate);
+ if (!PyErr_Occurred()) {
+ const char *msg;
+ msg = PQerrorMessage(conn->pgconn);
+ if (msg && *msg) { *error = strdup(msg); }
+ }
++ *tstate = PyEval_SaveThread();
+ goto cleanup;
+ }
+ if (PQresultStatus(*pgres) != PGRES_TUPLES_OK) { \ No newline at end of file
diff --git a/dev-python/psycopg/files/psycopg-2.4.2-setup.py.patch b/dev-python/psycopg/files/psycopg-2.4.2-setup.py.patch
new file mode 100644
index 000000000000..a35502270e1f
--- /dev/null
+++ b/dev-python/psycopg/files/psycopg-2.4.2-setup.py.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index e03876a..f5ec2ac 100644
+--- a/setup.py
++++ b/setup.py
+@@ -461,7 +461,7 @@ if parser.has_option('build_ext', 'mx_include_dir'):
+ mxincludedir = parser.get('build_ext', 'mx_include_dir')
+ else:
+ mxincludedir = os.path.join(get_python_inc(plat_specific=1), "mx")
+-if os.path.exists(mxincludedir):
++if not use_pydatetime and os.path.exists(mxincludedir):
+ # Build the support for mx: we will check at runtime if it can be imported
+ include_dirs.append(mxincludedir)
+ define_macros.append(('HAVE_MXDATETIME', '1')) \ No newline at end of file