summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-06 15:03:35 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-06 15:03:35 +0000
commitdde0a019cd2580bba57857fb6a372f9fb40199b6 (patch)
tree03d145305e96123925181b957133fdebadf7ace6 /dev-python/pmw/pmw-1.1.ebuild
parentFixing bug #6769 (diff)
downloadgentoo-2-dde0a019cd2580bba57857fb6a372f9fb40199b6.tar.gz
gentoo-2-dde0a019cd2580bba57857fb6a372f9fb40199b6.tar.bz2
gentoo-2-dde0a019cd2580bba57857fb6a372f9fb40199b6.zip
Removed RDEPEND="${DEPEND}"
Diffstat (limited to 'dev-python/pmw/pmw-1.1.ebuild')
-rw-r--r--dev-python/pmw/pmw-1.1.ebuild74
1 files changed, 33 insertions, 41 deletions
diff --git a/dev-python/pmw/pmw-1.1.ebuild b/dev-python/pmw/pmw-1.1.ebuild
index 3cbbea73b08c..17b738029fac 100644
--- a/dev-python/pmw/pmw-1.1.ebuild
+++ b/dev-python/pmw/pmw-1.1.ebuild
@@ -1,55 +1,47 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.1.ebuild,v 1.1 2002/10/24 22:02:22 agenkin Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.1.ebuild,v 1.2 2002/11/06 15:02:22 vapier Exp $
DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
HOMEPAGE="http://pmw.sourceforge.net/"
-
-DEPEND=">=dev-lang/python-2.1"
-RDEPEND="${DEPEND}"
+SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="MIT"
-
-SRC_URI="mirror://sourceforge/pmw/Pmw.${PV}.tar.gz"
-S="${WORKDIR}"/Pmw
+DEPEND=">=dev-lang/python-2.1"
+S="${WORKDIR}/Pmw"
src_compile() {
- if ! python -c "import Tkinter" >/dev/null 2>&1
- then
- die "You need to recompile Python with Tkinter support"
- fi
- python -c 'import compileall; compileall.compile_dir(".",force=1)'
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ die "You need to recompile Python with Tkinter support"
+ fi
+ python -c 'import compileall; compileall.compile_dir(".",force=1)'
}
-src_install () {
- # Figures out the destination directory, based on Python's version
- # installed.
- local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
- local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
-
- local dir
- for dir in `find . -type d`
- do
- # Skip the doc directory
- if [ `basename "${dir}"` = "doc" ]
- then
- continue
- fi
- insinto "${pmwdir}/${dir}"
- cd "${dir}"
- # Install all regular files in this dir
- local file
- for file in *
- do
- [ -f "${file}" ] && doins "${file}"
- done
- cd "${S}"
- done
-
- dodoc README
- local docdir=`find . -type d -name doc`
- dohtml -a html,gif,py "${docdir}"/*
+src_install() {
+ # Figures out the destination directory, based on Python's version installed.
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+ local pmwdir="/usr/lib/python${pv}/site-packages/Pmw"
+
+ local dir
+ for dir in `find . -type d` ; do
+ # Skip the doc directory
+ [ `basename "${dir}"` = "doc" ] && continue
+
+ insinto "${pmwdir}/${dir}"
+ cd "${dir}"
+ # Install all regular files in this dir
+ local file
+ for file in * ; do
+ [ -f "${file}" ] && doins "${file}"
+ done
+ cd "${S}"
+ done
+
+ dodoc README
+ local docdir=`find . -type d -name doc`
+ dohtml -a html,gif,py "${docdir}"/*
}