summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-07-24 07:38:52 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-07-24 07:38:52 +0000
commit9d9f3b0c0432f5011c844e2c480f9a2de8fda1a7 (patch)
tree865ee92c634f97185e9a713697b96a6e8e17493d /dev-python/pip
parentRemove the patches the LE path for them should not be executed nowdays. (diff)
downloadgentoo-2-9d9f3b0c0432f5011c844e2c480f9a2de8fda1a7.tar.gz
gentoo-2-9d9f3b0c0432f5011c844e2c480f9a2de8fda1a7.tar.bz2
gentoo-2-9d9f3b0c0432f5011c844e2c480f9a2de8fda1a7.zip
Version bump pip to 1.4.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/ChangeLog7
-rw-r--r--dev-python/pip/pip-1.4.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/pip/ChangeLog b/dev-python/pip/ChangeLog
index a271b09bcecb..77bda2653037 100644
--- a/dev-python/pip/ChangeLog
+++ b/dev-python/pip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.18 2013/05/03 19:35:02 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/ChangeLog,v 1.19 2013/07/24 07:38:52 djc Exp $
+
+*pip-1.4 (24 Jul 2013)
+
+ 24 Jul 2013; Dirkjan Ochtman <djc@gentoo.org> +pip-1.4.ebuild:
+ Version bump pip to 1.4.
03 May 2013; Robin H. Johnson <robbat2@gentoo.org> pip-1.2.1.ebuild,
pip-1.3.1.ebuild:
diff --git a/dev-python/pip/pip-1.4.ebuild b/dev-python/pip/pip-1.4.ebuild
new file mode 100644
index 000000000000..704e4447f04c
--- /dev/null
+++ b/dev-python/pip/pip-1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pip/pip-1.4.ebuild,v 1.1 2013/07/24 07:38:52 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="http://www.pip-installer.org/ http://pypi.python.org/pypi/pip/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ !<=app-misc/pip-1.2"
+DEPEND="${RDEPEND}"
+
+# required test data isn't bundled with the tarball
+RESTRICT="test"
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${PN}-1.3.1-unversioned.patch
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.txt docs/*.txt )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ ${EPYTHON} pip/runner.py completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ if use zsh-completion ; then
+ ${EPYTHON} pip/runner.py completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+ fi
+}