summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-05-12 06:08:40 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-05-12 06:08:40 +0000
commit47ed7021b4e94fc2aee29e4d570573c727b8dc9e (patch)
tree28df32b8a8b7308daa00d88e3551455b5cdcd5e4 /dev-python/pbr
parentbup (diff)
downloadgentoo-2-47ed7021b4e94fc2aee29e4d570573c727b8dc9e.tar.gz
gentoo-2-47ed7021b4e94fc2aee29e4d570573c727b8dc9e.tar.bz2
gentoo-2-47ed7021b4e94fc2aee29e4d570573c727b8dc9e.zip
bup
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/ChangeLog7
-rw-r--r--dev-python/pbr/pbr-0.11.0.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
index c09954b8404e..c1f7b7be9090 100644
--- a/dev-python/pbr/ChangeLog
+++ b/dev-python/pbr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pbr
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.33 2015/04/15 09:46:21 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.34 2015/05/12 06:08:40 prometheanfire Exp $
+
+*pbr-0.11.0 (12 May 2015)
+
+ 12 May 2015; Matthew Thode <prometheanfire@gentoo.org> +pbr-0.11.0.ebuild:
+ bup
*pbr-0.10.8 (15 Apr 2015)
diff --git a/dev-python/pbr/pbr-0.11.0.ebuild b/dev-python/pbr/pbr-0.11.0.ebuild
new file mode 100644
index 000000000000..3ccb20e0e237
--- /dev/null
+++ b/dev-python/pbr/pbr-0.11.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.11.0.ebuild,v 1.1 2015/05/12 06:08:40 prometheanfire Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/pip[${PYTHON_USEDEP}]"
+
+# Requ'd for testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ einfo "rogue tests disabled"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Note; removed tests pass once package is emerged,
+ # it's the suite's design that breaks form, not the tests' intended purpose
+ testr init || die
+ testr run || die "Testsuite failed under ${EPYTHON}"
+}