summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 01:55:21 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 01:55:21 +0000
commitda6046e2fa8d5ffcb33a2087317f23042933c286 (patch)
treef6d6767fc31076f38ab6346a63f56bf49e8c3156 /dev-python/paste
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-da6046e2fa8d5ffcb33a2087317f23042933c286.tar.gz
gentoo-2-da6046e2fa8d5ffcb33a2087317f23042933c286.tar.bz2
gentoo-2-da6046e2fa8d5ffcb33a2087317f23042933c286.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14469-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/ChangeLog6
-rw-r--r--dev-python/paste/paste-1.7.2.ebuild30
2 files changed, 21 insertions, 15 deletions
diff --git a/dev-python/paste/ChangeLog b/dev-python/paste/ChangeLog
index e71e743dae35..1be1e132465e 100644
--- a/dev-python/paste/ChangeLog
+++ b/dev-python/paste/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/paste
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.5 2009/04/26 09:15:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/ChangeLog,v 1.6 2009/10/01 01:55:21 arfrever Exp $
+
+ 01 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ paste-1.7.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*paste-1.7.2 (26 Apr 2009)
diff --git a/dev-python/paste/paste-1.7.2.ebuild b/dev-python/paste/paste-1.7.2.ebuild
index 5f3c0217a46b..f45fbb3ba229 100644
--- a/dev-python/paste/paste-1.7.2.ebuild
+++ b/dev-python/paste/paste-1.7.2.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.2.ebuild,v 1.1 2009/04/26 09:15:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paste/paste-1.7.2.ebuild,v 1.2 2009/10/01 01:55:21 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-KEYWORDS="~amd64 ~x86"
-
-MY_PN=Paste
-MY_P=${MY_PN}-${PV}
+MY_PN="Paste"
+MY_P="${MY_PN}-${PV}"
DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
HOMEPAGE="http://pythonpaste.org"
SRC_URI="http://cheeseshop.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
LICENSE="MIT"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="doc flup openid"
RDEPEND="flup? ( dev-python/flup )
@@ -23,11 +24,12 @@ RDEPEND="flup? ( dev-python/flup )
DEPEND="${RDEPEND}
dev-python/setuptools
doc? ( dev-python/pudge dev-python/buildutils )"
+RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
-src_unpack() {
- distutils_src_unpack
+src_prepare() {
+ distutils_src_prepare
sed -i \
-e '/highlighter/d' \
@@ -36,15 +38,15 @@ src_unpack() {
src_compile() {
distutils_src_compile
- if use doc ; then
- einfo "Generating docs as requested..."
- PYTHONPATH=. "${python}" setup.py pudge || die "generating docs failed"
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH=. "${python}" setup.py pudge || die "Generation of documentation failed"
fi
}
+# src_test() needs py.test but there's no release yet.
+
src_install() {
distutils_src_install
use doc && dohtml -r docs/html/*
}
-
-# src_test() needs py.test but there's no release yet