summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-03-08 20:20:34 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-03-08 20:20:34 +0000
commit72c9510136ffdbe6ee1b5d0cc5cec3f01bbd685d (patch)
tree9c894a1522e71f566b8c63f1498c09b31fed2e78 /dev-python/paisley
parentAdd prefix keywords, inject $EPREFIX as needed (diff)
downloadgentoo-2-72c9510136ffdbe6ee1b5d0cc5cec3f01bbd685d.tar.gz
gentoo-2-72c9510136ffdbe6ee1b5d0cc5cec3f01bbd685d.tar.bz2
gentoo-2-72c9510136ffdbe6ee1b5d0cc5cec3f01bbd685d.zip
Version bump paisley to 0.3.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/paisley')
-rw-r--r--dev-python/paisley/ChangeLog9
-rw-r--r--dev-python/paisley/paisley-0.3.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-python/paisley/ChangeLog b/dev-python/paisley/ChangeLog
index bb00c3ed2cf7..6da1bd570e9e 100644
--- a/dev-python/paisley/ChangeLog
+++ b/dev-python/paisley/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/paisley
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/ChangeLog,v 1.8 2010/12/18 19:26:35 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/ChangeLog,v 1.9 2011/03/08 20:20:34 djc Exp $
+
+*paisley-0.3 (08 Mar 2011)
+
+ 08 Mar 2011; Dirkjan Ochtman <djc@gentoo.org> +paisley-0.3.ebuild:
+ Version bump to 0.3.
18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
paisley-0.1.ebuild:
diff --git a/dev-python/paisley/paisley-0.3.ebuild b/dev-python/paisley/paisley-0.3.ebuild
new file mode 100644
index 000000000000..4a08ae8a40e0
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paisley/paisley-0.3.ebuild,v 1.1 2011/03/08 20:20:34 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application."
+HOMEPAGE="http://launchpad.net/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson
+ dev-python/twisted
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="paisley.py"