summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-06 07:47:04 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-06 07:47:04 +0000
commit6bfd4e8e11b873f372787ac3c82ce89493179578 (patch)
tree0e8b84e297080908ab651cc1fcc32cdc2a59b792 /dev-python/oauthlib
parentInstall helpers needed for completions as well, bug #520032. (diff)
downloadgentoo-2-6bfd4e8e11b873f372787ac3c82ce89493179578.tar.gz
gentoo-2-6bfd4e8e11b873f372787ac3c82ce89493179578.tar.bz2
gentoo-2-6bfd4e8e11b873f372787ac3c82ce89493179578.zip
re-add py3.2 to support reverse deps, fix syntax in RDEPEND
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/ChangeLog5
-rw-r--r--dev-python/oauthlib/oauthlib-0.6.3.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/oauthlib/ChangeLog b/dev-python/oauthlib/ChangeLog
index c1457ef4ed24..9f01460b56e7 100644
--- a/dev-python/oauthlib/ChangeLog
+++ b/dev-python/oauthlib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/oauthlib
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.34 2014/07/06 12:44:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.35 2014/09/06 07:47:04 idella4 Exp $
+
+ 06 Sep 2014; Ian Delaney <idella4@gentoo.org> oauthlib-0.6.3.ebuild:
+ re-add py3.2 to support reverse deps, fix syntax in RDEPEND
06 Jul 2014; Michał Górny <mgorny@gentoo.org> oauthlib-0.1.3.ebuild,
oauthlib-0.3.0.ebuild, oauthlib-0.6.1.ebuild, oauthlib-0.6.3.ebuild:
diff --git a/dev-python/oauthlib/oauthlib-0.6.3.ebuild b/dev-python/oauthlib/oauthlib-0.6.3.ebuild
index 539e8670a74b..d6d597f6869e 100644
--- a/dev-python/oauthlib/oauthlib-0.6.3.ebuild
+++ b/dev-python/oauthlib/oauthlib-0.6.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-0.6.3.ebuild,v 1.2 2014/07/06 12:44:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-0.6.3.ebuild,v 1.3 2014/09/06 07:47:04 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
inherit distutils-r1
@@ -18,7 +18,7 @@ IUSE="test"
# >=pycrypto-2.6-r1 for python3 support
# unittest2 for python2 compat
-RDEPEND=">=dev-python/pycrypto-2.6-r1"
+RDEPEND=">=dev-python/pycrypto-2.6-r1[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (