summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-02 15:14:13 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-02 15:14:13 +0000
commite567aa45d95307bfb358dfc37fb731a97261d7ca (patch)
tree23876455840f972a2747273223f8edb53261e6b1 /dev-python/nltk
parentStable for HPPA (bug #502822). (diff)
downloadgentoo-2-e567aa45d95307bfb358dfc37fb731a97261d7ca.tar.gz
gentoo-2-e567aa45d95307bfb358dfc37fb731a97261d7ca.tar.bz2
gentoo-2-e567aa45d95307bfb358dfc37fb731a97261d7ca.zip
Version bump to 2.0.4, migrated to distutils-r1; proxied commit for Corentin LABBE.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/ChangeLog10
-rw-r--r--dev-python/nltk/nltk-2.0.4.ebuild25
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/nltk/ChangeLog b/dev-python/nltk/ChangeLog
index d0208dc1a291..163e5fed5a87 100644
--- a/dev-python/nltk/ChangeLog
+++ b/dev-python/nltk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nltk
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.15 2013/03/17 17:59:45 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/ChangeLog,v 1.16 2014/04/02 15:14:13 tomwij Exp $
+
+*nltk-2.0.4 (02 Apr 2014)
+
+ 02 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +nltk-2.0.4.ebuild:
+ Version bump to 2.0.4, migrated to distutils-r1; proxied commit for Corentin
+ LABBE.
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-python/nltk/nltk-2.0.4.ebuild b/dev-python/nltk/nltk-2.0.4.ebuild
new file mode 100644
index 000000000000..c6a30405f76e
--- /dev/null
+++ b/dev-python/nltk/nltk-2.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nltk/nltk-2.0.4.ebuild,v 1.1 2014/04/02 15:14:13 tomwij Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="tk(+),xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"