summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-06-01 04:04:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-06-01 04:04:58 +0000
commite8ca99aca156b8dbe273f82a15b1476e2cc6c3c6 (patch)
treec2dae307485844e81096e10c5f7c61d086f4c5da /dev-python/netlib
parentBump (diff)
downloadgentoo-2-e8ca99aca156b8dbe273f82a15b1476e2cc6c3c6.tar.gz
gentoo-2-e8ca99aca156b8dbe273f82a15b1476e2cc6c3c6.tar.bz2
gentoo-2-e8ca99aca156b8dbe273f82a15b1476e2cc6c3c6.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/netlib')
-rw-r--r--dev-python/netlib/ChangeLog7
-rw-r--r--dev-python/netlib/netlib-0.12.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-python/netlib/ChangeLog b/dev-python/netlib/ChangeLog
index a4b0916b6568..2c8560a61ad9 100644
--- a/dev-python/netlib/ChangeLog
+++ b/dev-python/netlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/netlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/netlib/ChangeLog,v 1.11 2015/04/08 08:05:19 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netlib/ChangeLog,v 1.12 2015/06/01 04:04:58 patrick Exp $
+
+*netlib-0.12.0 (01 Jun 2015)
+
+ 01 Jun 2015; Patrick Lauer <patrick@gentoo.org> +netlib-0.12.0.ebuild:
+ Bump
08 Apr 2015; Michał Górny <mgorny@gentoo.org> netlib-0.10.ebuild:
Drop old Python implementations
diff --git a/dev-python/netlib/netlib-0.12.0.ebuild b/dev-python/netlib/netlib-0.12.0.ebuild
new file mode 100644
index 000000000000..2382f2b9f612
--- /dev/null
+++ b/dev-python/netlib/netlib-0.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/netlib/netlib-0.12.0.ebuild,v 1.1 2015/06/01 04:04:58 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Collection of network utility classes used by pathod and mitmproxy"
+HOMEPAGE="https://github.com/cortesi/netlib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ =www-servers/pathod-$(get_version_component_range 1-2)*[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}