summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-09 15:47:03 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-09 15:47:03 +0000
commitf9c8b0a3cd749cf7aacfadcdbe76716d5e66d526 (patch)
treee524506551cbda565e9d646e92db3f172351db38 /dev-python/mygpoclient
parentVersion bump. Bug #460898 (diff)
downloadgentoo-2-f9c8b0a3cd749cf7aacfadcdbe76716d5e66d526.tar.gz
gentoo-2-f9c8b0a3cd749cf7aacfadcdbe76716d5e66d526.tar.bz2
gentoo-2-f9c8b0a3cd749cf7aacfadcdbe76716d5e66d526.zip
revbump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/mygpoclient')
-rw-r--r--dev-python/mygpoclient/ChangeLog8
-rw-r--r--dev-python/mygpoclient/files/tests.patch34
-rw-r--r--dev-python/mygpoclient/mygpoclient-1.7-r1.ebuild46
3 files changed, 87 insertions, 1 deletions
diff --git a/dev-python/mygpoclient/ChangeLog b/dev-python/mygpoclient/ChangeLog
index cc7fa712debe..39b6ad4575d1 100644
--- a/dev-python/mygpoclient/ChangeLog
+++ b/dev-python/mygpoclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mygpoclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mygpoclient/ChangeLog,v 1.4 2013/02/22 05:57:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mygpoclient/ChangeLog,v 1.5 2013/03/09 15:47:03 idella4 Exp $
+
+*mygpoclient-1.7-r1 (09 Mar 2013)
+
+ 09 Mar 2013; Ian Delaney <idella4@gentoo.org> +files/tests.patch,
+ +mygpoclient-1.7-r1.ebuild:
+ revbump
*mygpoclient-1.7 (22 Feb 2013)
diff --git a/dev-python/mygpoclient/files/tests.patch b/dev-python/mygpoclient/files/tests.patch
new file mode 100644
index 000000000000..041cee501a00
--- /dev/null
+++ b/dev-python/mygpoclient/files/tests.patch
@@ -0,0 +1,34 @@
+diff -ur mygpoclient-1.7.orig/mygpoclient/locator_test.py mygpoclient-1.7/mygpoclient/locator_test.py
+--- mygpoclient-1.7.orig/mygpoclient/locator_test.py 2013-02-08 19:39:32.000000000 +0800
++++ mygpoclient-1.7/mygpoclient/locator_test.py 2013-03-09 23:33:37.137651841 +0800
+@@ -16,7 +16,7 @@
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ from mygpoclient import locator
+-import unittest
++import unittest, sys
+
+ class Test_Exceptions(unittest.TestCase):
+ def setUp(self):
+@@ -54,18 +54,21 @@
+ podcast='http://example.org/episodes.rss',
+ device_id='gpodder')
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+ def test_device_settings_uri_exception(self):
+ """Test if using no parameter for a device Setting raises a ValueError"""
+ self.assertRaises(ValueError,
+ self.locator.settings_uri, type='device',
+ scope_param1=None, scope_param2=None)
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+ def test_podcast_settings_uri_exception(self):
+ """Test if using no parameter for a podcast Setting raises a ValueError"""
+ self.assertRaises(ValueError,
+ self.locator.settings_uri, type='podcast',
+ scope_param1=None, scope_param2=None)
+
++ @unittest.skipIf(hasattr(sys, 'pypy_version_info'), "pypy doesn't raise ValueError")
+ def test_episode_settings_uri_exception(self):
+ """Test if only using one parameter for a episode Setting raises a ValueError"""
+ self.assertRaises(ValueError,
diff --git a/dev-python/mygpoclient/mygpoclient-1.7-r1.ebuild b/dev-python/mygpoclient/mygpoclient-1.7-r1.ebuild
new file mode 100644
index 000000000000..366a044f2997
--- /dev/null
+++ b/dev-python/mygpoclient/mygpoclient-1.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mygpoclient/mygpoclient-1.7-r1.ebuild,v 1.1 2013/03/09 15:47:03 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy{1_9,2_0} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A gpodder.net client library"
+HOMEPAGE="http://thp.io/2010/mygpoclient/"
+SRC_URI="http://thp.io/2010/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/minimock
+ )"
+
+PATCHES=( "${FILESDIR}"/tests.patch )
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # Disable tests requring network connection.
+ rm -f mygpoclient/http_test.py
+}
+
+python_test() {
+ if [[ "${EPYTHON:0:4}" == "pypy" ]]; then
+ nosetests --cover-erase --with-coverage --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
+ else
+ nosetests --cover-erase --with-coverage --with-doctest --cover-package=mygpoclient "${BUILD_DIR}"/lib/${PN}/
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ rm -f $(find "${D}" -name "*_test.py")
+}