summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-08-26 09:09:53 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-08-26 09:09:53 +0000
commit36079f8e1224134ac0901a16ed7c271b6ac795b3 (patch)
tree31f3b4faeba232e9927bf34cc5db1aad01f51a8f /dev-python/mpmath
parentalpha/ia64/sparc stable wrt #235676 (diff)
downloadgentoo-2-36079f8e1224134ac0901a16ed7c271b6ac795b3.tar.gz
gentoo-2-36079f8e1224134ac0901a16ed7c271b6ac795b3.tar.bz2
gentoo-2-36079f8e1224134ac0901a16ed7c271b6ac795b3.zip
Version bump, new USE flag gmp
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-tuxonice-r1 i686)
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/ChangeLog7
-rw-r--r--dev-python/mpmath/mpmath-0.9.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/mpmath/ChangeLog b/dev-python/mpmath/ChangeLog
index d073d99dc7c5..3699bf62a0f7 100644
--- a/dev-python/mpmath/ChangeLog
+++ b/dev-python/mpmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mpmath
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.1 2008/07/08 04:10:15 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/ChangeLog,v 1.2 2008/08/26 09:09:53 grozin Exp $
+
+*mpmath-0.9 (26 Aug 2008)
+
+ 26 Aug 2008; Andrey Grozin <grozin@gentoo.org> +mpmath-0.9.ebuild:
+ Version bump, new USE flag gmp
*mpmath-0.8 (08 Jul 2008)
diff --git a/dev-python/mpmath/mpmath-0.9.ebuild b/dev-python/mpmath/mpmath-0.9.ebuild
new file mode 100644
index 000000000000..d1088fe640ba
--- /dev/null
+++ b/dev-python/mpmath/mpmath-0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpmath/mpmath-0.9.ebuild,v 1.1 2008/08/26 09:09:53 grozin Exp $
+
+NEED_PYTHON=2.4
+inherit distutils
+
+DESCRIPTION="A python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://code.google.com/p/${PN}/"
+SRC_URI="http://mpmath.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples gmp test"
+
+DEPEND="doc? ( dev-python/sphinx )
+ gmp? ( dev-python/gmpy )
+ test? ( dev-python/py )"
+
+src_install() {
+ DOCS="CHANGES"
+ distutils_src_install
+
+ if use doc; then
+ cd doc
+ "${python}" build.py
+ dohtml -r build/*
+ cd ..
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demo/*
+ fi
+}
+
+src_test() {
+ cd mpmath/tests
+ py.test || die "tests failed"
+}