summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-28 13:39:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-28 13:39:12 +0000
commit07ecc52e702967a58636f09495d1693d48d7862c (patch)
tree1c6e1191ac64c6dcbbd4f87ebd1defd1b9c44045 /dev-python/mod_python
parentnew upstream version (Manifest recommit) (diff)
downloadgentoo-2-07ecc52e702967a58636f09495d1693d48d7862c.tar.gz
gentoo-2-07ecc52e702967a58636f09495d1693d48d7862c.tar.bz2
gentoo-2-07ecc52e702967a58636f09495d1693d48d7862c.zip
fix missing mod_python.so, add python postinst pyc/pyo generation (#39627)
Diffstat (limited to 'dev-python/mod_python')
-rw-r--r--dev-python/mod_python/ChangeLog7
-rw-r--r--dev-python/mod_python/files/digest-mod_python-3.0.4-r11
-rw-r--r--dev-python/mod_python/mod_python-3.0.4-r1.ebuild60
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/mod_python/ChangeLog b/dev-python/mod_python/ChangeLog
index bec16b1ec910..2610dd8ad45b 100644
--- a/dev-python/mod_python/ChangeLog
+++ b/dev-python/mod_python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mod_python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.12 2004/01/24 21:06:45 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/ChangeLog,v 1.13 2004/01/28 13:39:11 liquidx Exp $
+
+*mod_python-3.0.4-r1 (28 Jan 2004)
+
+ 28 Jan 2004; Alastair Tse <liquidx@gentoo.org> mod_python-3.0.4-r1.ebuild:
+ fix missing mod_python.so, add python postinst pyc/pyo generation (#39627)
*mod_python-2.7.10 (24 Jan 2004)
diff --git a/dev-python/mod_python/files/digest-mod_python-3.0.4-r1 b/dev-python/mod_python/files/digest-mod_python-3.0.4-r1
new file mode 100644
index 000000000000..3eefc4f3ee99
--- /dev/null
+++ b/dev-python/mod_python/files/digest-mod_python-3.0.4-r1
@@ -0,0 +1 @@
+MD5 d4a51a049f84c5150878625911d8f1d5 mod_python-3.0.4.tgz 218692
diff --git a/dev-python/mod_python/mod_python-3.0.4-r1.ebuild b/dev-python/mod_python/mod_python-3.0.4-r1.ebuild
new file mode 100644
index 000000000000..b5c9ee4d3368
--- /dev/null
+++ b/dev-python/mod_python/mod_python-3.0.4-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mod_python/mod_python-3.0.4-r1.ebuild,v 1.1 2004/01/28 13:39:12 liquidx Exp $
+
+inherit python
+
+DESCRIPTION="An Apache2 DSO providing an embedded Python interpreter"
+HOMEPAGE="http://www.modpython.org/"
+SRC_URI="http://www.apache.org/dist/httpd/modpython/${P}.tgz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/python
+ >=net-www/apache-2.0"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+ sed -i -e 's:mod_python.so :mod_python.so $(DESTDIR):' Makefile.in
+ # remove optimisations, we do that outside portage
+ sed -i -e 's:--optimize 2:--prefix=${DESTDIR}/usr --no-compile:' dist/Makefile.in
+
+ # Fix compilation when using Python-2.3
+ has_version ">=dev-lang/python-2.3" && \
+ sed -i -e 's:LONG_LONG:PY_LONG_LONG:g' \
+ "${S}/src/requestobject.c"
+}
+
+src_compile() {
+ ./configure --with-apxs=/usr/sbin/apxs2 || die
+ make OPT="`apxs2 -q CFLAGS` -fPIC" || die
+}
+
+src_install() {
+ dodir /usr/lib/apache2-extramodules
+ make install DESTDIR=${D} LIBEXECDIR=/usr/lib/apache2-extramodules || die
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/16_mod_python.conf
+ dodoc ${FILESDIR}/16_mod_python.conf README NEWS CREDITS COPYRIGHT
+ dohtml doc-html/*
+ insinto /usr/share/doc/${P}/html/icons
+ doins doc-html/icons/*
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/mod_python
+
+ einfo "To have Apache run python programs, please do the following:"
+ einfo "Edit /etc/conf.d/apache2 and add \"-D PYTHON\""
+ einfo "That will setup Apache to load python when it starts."
+ einfo
+ einfo "If you're new to mod_python there's a manual and tutorial"
+ einfo "installed in /usr/share/doc/${P}/html/index.html."
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}