summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-24 04:25:19 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-24 04:25:19 +0000
commitfb4fb27f3dba91af8c0efd077503b18eeb595ec0 (patch)
treeb82a0f8a447c1d1330e7d4c2e256cb512795674d /dev-python/matplotlib
parentremove vuln version wrt bug 271746 (diff)
downloadgentoo-2-fb4fb27f3dba91af8c0efd077503b18eeb595ec0.tar.gz
gentoo-2-fb4fb27f3dba91af8c0efd077503b18eeb595ec0.tar.bz2
gentoo-2-fb4fb27f3dba91af8c0efd077503b18eeb595ec0.zip
Version bump
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/matplotlib-0.99.1.1.ebuild180
2 files changed, 187 insertions, 1 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index fb01fb3c5125..f8124f9a6987 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.69 2009/08/08 03:27:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.70 2009/09/24 04:25:19 bicatali Exp $
+
+*matplotlib-0.99.1.1 (24 Sep 2009)
+
+ 24 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +matplotlib-0.99.1.1.ebuild:
+ Version bump
*matplotlib-0.99.0 (08 Aug 2009)
diff --git a/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
new file mode 100644
index 000000000000..e931f3d4a719
--- /dev/null
+++ b/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.99.1.1.ebuild,v 1.1 2009/09/24 04:25:19 bicatali Exp $
+
+WX_GTK_VER=2.8
+EAPI=2
+inherit distutils wxwidgets
+
+PDOC="users_guide_${PV}"
+
+DESCRIPTION="Pure python plotting library with matlab like syntax"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE="cairo doc excel examples fltk gtk latex qt3 qt4 traits tk wxwidgets"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="PYTHON BSD"
+
+CDEPEND=">=dev-python/numpy-1.1
+ dev-python/python-dateutil
+ dev-python/pytz
+ media-libs/freetype:2
+ media-libs/libpng
+ gtk? ( dev-python/pygtk )
+ tk? ( dev-lang/python[tk] )
+ wxwidgets? ( dev-python/wxpython:2.8 )"
+
+DEPEND="${CDEPEND}
+ dev-python/pycxx
+ dev-util/pkgconfig
+ doc? (
+ >=dev-python/sphinx-0.5.1
+ || (
+ >=media-gfx/graphviz-2.24.0[cairo]
+ <media-gfx/graphviz-2.24.0[cairo,png]
+ )
+ || ( ( dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended )
+ ( app-text/ptex dev-tex/latex-unicode ) )
+ app-text/dvipng
+ dev-python/ipython )"
+
+RDEPEND="${CDEPEND}
+ || ( media-fonts/dejavu media-fonts/ttf-bitstream-vera )
+ media-fonts/texcm-ttf
+ cairo? ( dev-python/pycairo )
+ excel? ( dev-python/xlwt )
+ fltk? ( dev-python/pyfltk )
+ qt3? ( dev-python/PyQt )
+ qt4? ( dev-python/PyQt4[X] )
+ traits? ( dev-python/traits dev-python/configobj )
+ latex? (
+ virtual/latex-base
+ virtual/ghostscript
+ app-text/dvipng
+ virtual/poppler-utils
+ || ( dev-texlive/texlive-fontsrecommended
+ app-text/ptex ) )"
+
+DOCS="INTERACTIVE"
+
+use_setup() {
+ local uword="${2}"
+ [ -z "${2}" ] && uword="${1}"
+ if use ${1}; then
+ echo "${uword} = True"
+ echo "${uword}agg = True"
+ else
+ echo "${uword} = False"
+ echo "${uword}agg = False"
+ fi
+}
+
+src_prepare() {
+ # patch from mandriva
+ #epatch "${FILESDIR}"/${PN}-0.98.5.2-literal.patch
+ # avoid to launch xv while building examples docs
+ epatch "${FILESDIR}"/${PN}-0.98.5.2-no-xv.patch
+
+ # create setup.cfg (see setup.cfg.template for any changes)
+ cat > setup.cfg <<-EOF
+ [provide_packages]
+ pytz = False
+ dateutil = False
+ configobj = False
+ enthought.traits = False
+ [gui_support]
+ $(use_setup gtk)
+ $(use_setup tk)
+ $(use_setup wxwidgets wx)
+ $(use_setup qt3 qt)
+ $(use_setup qt4)
+ $(use_setup fltk)
+ $(use_setup cairo)
+ EOF
+
+ # avoid checks needing a X display
+ sed -i \
+ -e "s/check_for_gtk()/$(use gtk && echo True || echo False)/" \
+ -e "s/check_for_tk()/$(use tk && echo True || echo False)/" \
+ setup.py || die "sed setup.py failed"
+
+ # respect FHS:
+ # - mpl-data in /usr/share/matplotlib
+ # - config files in /etc/matplotlib
+ sed -i \
+ -e "/'mpl-data\/matplotlibrc',/d" \
+ -e "/'mpl-data\/matplotlib.conf',/d" \
+ -e "s:'lib/matplotlib/mpl-data/matplotlibrc':'matplotlibrc':" \
+ -e "s:'lib/matplotlib/mpl-data/matplotlib.conf':'matplotlib.conf':" \
+ setup.py \
+ || die "sed setup.py for FHS failed"
+
+ sed -i \
+ -e "s:path = get_data_path():path = '/etc/matplotlib':" \
+ -e "s:os.path.dirname(__file__):'/usr/share/${PN}':g" \
+ lib/matplotlib/{__init__,config/cutils}.py \
+ || die "sed init for FHS failed"
+
+ # remove internal copies of fonts, pycxx, pyparsing
+ rm -rf \
+ CXX \
+ lib/matplotlib/mpl-data/fonts/{afm,pdfcorefonts} \
+ lib/matplotlib/mpl-data/fonts/ttf/{Vera*,cm*,*.TXT} \
+ || die "removed internal copies failed"
+ ln -s /usr/share/python*/CXX . || die
+
+ # remove pyparsing only when upstream pyparsing included matplotlib
+ # fixes. See bug #260025
+ #rm -f lib/matplotlib/pyparsing.py
+}
+
+src_compile() {
+ unset DISPLAY # bug #278524
+ distutils_src_compile
+ if use doc; then
+ cd "${S}/doc"
+ export VARTEXFONTS="${T}"/fonts
+ # no die function here: broken compilation at the end, do it twice,
+ # result ok.
+ MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
+ PYTHONPATH=$(dir -d "${S}"/build/lib*) \
+ ${python} make.py html
+ MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \
+ PYTHONPATH=$(dir -d "${S}"/build/lib*) \
+ ${python} make.py
+ fi
+}
+
+src_test() {
+ einfo "Tests are quite long, be patient"
+ cd "${S}/examples/tests"
+ PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py agg \
+ || die "tests failed"
+ PYTHONPATH=$(dir -d "${S}"/build/lib*) ${python} backend_driver.py \
+ --clean
+}
+
+src_install() {
+ distutils_src_install
+
+ # respect FHS
+ dodir /usr/share/${PN}
+ mv "${D}"/usr/*/*/site-packages/${PN}/{mpl-data,backends/Matplotlib.nib} \
+ "${D}"/usr/share/${PN} || die "failed renaming"
+ insinto /etc/matplotlib
+ doins matplotlibrc matplotlib.conf \
+ || die "installing config files failed"
+
+ # doc and examples
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins doc/build/latex/Matplotlib.pdf || die
+ doins -r doc/build/html || die
+ fi
+ if use examples; then
+ doins -r examples || die
+ fi
+}