summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-27 17:49:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-27 17:49:50 +0000
commit47484ca68c197e3347e20f68c26f21f8a4511e86 (patch)
tree6025eea1e2e83d323631ef9705803288b2e35853 /dev-python/matplotlib
parentRemove p.mask for media-video/mplayer-20090226.28734 (diff)
downloadgentoo-2-47484ca68c197e3347e20f68c26f21f8a4511e86.tar.gz
gentoo-2-47484ca68c197e3347e20f68c26f21f8a4511e86.tar.bz2
gentoo-2-47484ca68c197e3347e20f68c26f21f8a4511e86.zip
Added more dependencies to build documentation and a patch to avoid to launch xv during doc compilation when imaging is installed. Closing bug #260446 and bug #260431
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog8
-rw-r--r--dev-python/matplotlib/files/matplotlib-0.98.5.2-no-xv.patch11
-rw-r--r--dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild16
3 files changed, 30 insertions, 5 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index ef069d9e735e..637e545c7445 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.59 2009/02/25 20:33:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.60 2009/02/27 17:49:50 bicatali Exp $
+
+ 27 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/matplotlib-0.98.5.2-no-xv.patch, matplotlib-0.98.5.2-r3.ebuild:
+ Added more dependencies to build documentation and a patch to avoid to
+ launch xv during doc compilation when imaging is installed. Closing bug
+ #260446 and bug #260431
*matplotlib-0.98.5.2-r3 (25 Feb 2009)
diff --git a/dev-python/matplotlib/files/matplotlib-0.98.5.2-no-xv.patch b/dev-python/matplotlib/files/matplotlib-0.98.5.2-no-xv.patch
new file mode 100644
index 000000000000..65ad17b3661d
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-0.98.5.2-no-xv.patch
@@ -0,0 +1,11 @@
+--- examples/pylab_examples/to_numeric.py.orig 2009-02-27 17:10:43.000000000 +0000
++++ examples/pylab_examples/to_numeric.py 2009-02-27 17:06:20.000000000 +0000
+@@ -28,6 +28,6 @@
+ X = fromstring(s, uint8)
+ X.shape = h, w, 3
+
+-im = Image.fromstring( "RGB", (w,h), s)
+-im.show()
++im = imshow(Image.fromstring( "RGB", (w,h), s),origin='lower')
++show()
+
diff --git a/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild b/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild
index cf2c4c0ef999..e7e7669e3746 100644
--- a/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild
+++ b/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild,v 1.1 2009/02/25 20:33:41 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-0.98.5.2-r3.ebuild,v 1.2 2009/02/27 17:49:50 bicatali Exp $
WX_GTK_VER=2.8
EAPI=2
@@ -29,9 +29,14 @@ CDEPEND=">=dev-python/numpy-1.1
DEPEND="${CDEPEND}
dev-python/pycxx
dev-util/pkgconfig
- doc? ( >=dev-python/sphinx-0.5.1
- app-text/dvipng
- dev-python/ipython )"
+ doc? (
+ >=dev-python/sphinx-0.5.1
+ || ( ( dev-texlive/texlive-latexextra
+ dev-texlive/texlive-latexrecommended )
+ app-text/tetex
+ app-text/ptex )
+ app-text/dvipng
+ dev-python/ipython )"
RDEPEND="${CDEPEND}
|| ( media-fonts/dejavu media-fonts/ttf-bitstream-vera )
@@ -68,6 +73,8 @@ use_setup() {
src_prepare() {
# patch from mandriva
epatch "${FILESDIR}"/${P}-literal.patch
+ # avoid to launch xv while building examples docs
+ epatch "${FILESDIR}"/${P}-no-xv.patch
# create setup.cfg (see setup.cfg.template for any changes)
cat > setup.cfg <<-EOF
@@ -126,6 +133,7 @@ src_compile() {
distutils_src_compile
if use doc; then
cd "${S}/doc"
+ export VARTEXFONTS="${T}"/fonts
# no die function here: broken compilation at the end, do it twice,
# result ok.
MATPLOTLIBDATA="${S}/lib/matplotlib/mpl-data" \