summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-11-23 12:01:09 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-11-23 12:01:09 +0000
commit721abf4d3283f8b2bd953b7c3f6a80c5e2a8598c (patch)
treebb8e1afbe9c4cb7e95321e38e436d1548f9f27ac /dev-python/m2crypto/m2crypto-0.12.ebuild
parentversion bump. should fix openssl/python-2.3 problems (#33971) (diff)
downloadgentoo-2-721abf4d3283f8b2bd953b7c3f6a80c5e2a8598c.tar.gz
gentoo-2-721abf4d3283f8b2bd953b7c3f6a80c5e2a8598c.tar.bz2
gentoo-2-721abf4d3283f8b2bd953b7c3f6a80c5e2a8598c.zip
version bump. should fix openssl/python-2.3 problems (#33971)
Diffstat (limited to 'dev-python/m2crypto/m2crypto-0.12.ebuild')
-rw-r--r--dev-python/m2crypto/m2crypto-0.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.12.ebuild b/dev-python/m2crypto/m2crypto-0.12.ebuild
new file mode 100644
index 000000000000..a37dd1260325
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/m2crypto/m2crypto-0.12.ebuild,v 1.1 2003/11/23 12:01:04 liquidx Exp $
+
+inherit distutils
+
+DESCRIPTION="A python wrapper for the OpenSSL crypto library"
+HOMEPAGE="http://www.post1.com/home/ngps/m2/"
+SRC_URI="http://sandbox.rulemaker.net/ngps/Dist/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.7"
+
+PYTHON_MODNAME="M2Crypto"
+
+src_install () {
+ DOCS="README SWIG BUGS CHANGES STORIES LICENCE"
+ distutils_src_install
+ # can't dodoc, doesn't handle subdirs
+ dodir /usr/share/doc/${PF}/example
+ cp -a demo/* ${D}/usr/share/doc/${PF}/example
+ dohtml -r doc/*
+}