summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-15 09:04:44 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-15 09:04:44 +0000
commit3883ae5561e30cb38afd600c522c664db41c9e04 (patch)
treeebf9d92fc67e748db88721c027c3c73d6072eb2a /dev-python/lp_solve
parentmigrate -> distutils-r1, add IUSE doc (diff)
downloadgentoo-2-3883ae5561e30cb38afd600c522c664db41c9e04.tar.gz
gentoo-2-3883ae5561e30cb38afd600c522c664db41c9e04.tar.bz2
gentoo-2-3883ae5561e30cb38afd600c522c664db41c9e04.zip
Minor refinements
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/lp_solve')
-rw-r--r--dev-python/lp_solve/ChangeLog5
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild20
2 files changed, 18 insertions, 7 deletions
diff --git a/dev-python/lp_solve/ChangeLog b/dev-python/lp_solve/ChangeLog
index f019622ebb84..3442f8311833 100644
--- a/dev-python/lp_solve/ChangeLog
+++ b/dev-python/lp_solve/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/lp_solve
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/ChangeLog,v 1.4 2013/02/27 19:00:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/ChangeLog,v 1.5 2013/07/15 09:04:44 idella4 Exp $
+
+ 15 Jul 2013; Ian Delaney <idella4@gentoo.org> lp_solve-5.5.2.0-r1.ebuild:
+ Minor refinements
*lp_solve-5.5.2.0-r1 (27 Feb 2013)
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
index cf7b2c933a6e..b553ca1da8ae 100644
--- a/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild,v 1.1 2013/02/27 19:00:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0-r1.ebuild,v 1.2 2013/07/15 09:04:44 idella4 Exp $
EAPI=5
@@ -27,14 +27,22 @@ S="${WORKDIR}/${PN}_5.5/extra/Python/"
PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv ex*py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
python_test() {
- PYTHONPATH="$(ls -d ${BUILD_DIR}/lib.*)" "${EPYTHON}" lpdemo.py || die
+ "${PYTHON}" lpdemo.py || die
}
-src_install() {
- distutils-r1_src_install
+python_install_all() {
dodoc changes
use doc && dohtml Python.htm
- insinto /usr/share/doc/${PF}/examples
- use examples && doins ex*py
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
}