summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-09 04:42:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-09 04:42:31 +0000
commite0ff4df146bd8737f786021c2c18e679a2fc37d1 (patch)
treec35ea5e371d8f1250ab48d3b5f748b231ae0439d /dev-python/imdbpy
parentVersion bump for Cinnamon 2.2. (diff)
downloadgentoo-2-e0ff4df146bd8737f786021c2c18e679a2fc37d1.tar.gz
gentoo-2-e0ff4df146bd8737f786021c2c18e679a2fc37d1.tar.bz2
gentoo-2-e0ff4df146bd8737f786021c2c18e679a2fc37d1.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/imdbpy')
-rw-r--r--dev-python/imdbpy/ChangeLog7
-rw-r--r--dev-python/imdbpy/imdbpy-5.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/imdbpy/ChangeLog b/dev-python/imdbpy/ChangeLog
index 4fe0c1c3e7a8..e495e344707c 100644
--- a/dev-python/imdbpy/ChangeLog
+++ b/dev-python/imdbpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/imdbpy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/imdbpy/ChangeLog,v 1.22 2014/03/31 21:16:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imdbpy/ChangeLog,v 1.23 2014/05/09 04:42:31 patrick Exp $
+
+*imdbpy-5.0 (09 May 2014)
+
+ 09 May 2014; Patrick Lauer <patrick@gentoo.org> +imdbpy-5.0.ebuild:
+ Bump
31 Mar 2014; Michał Górny <mgorny@gentoo.org> imdbpy-4.9-r1.ebuild:
Add support for the new PyPy slotting.
diff --git a/dev-python/imdbpy/imdbpy-5.0.ebuild b/dev-python/imdbpy/imdbpy-5.0.ebuild
new file mode 100644
index 000000000000..b071a7558591
--- /dev/null
+++ b/dev-python/imdbpy/imdbpy-5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/imdbpy/imdbpy-5.0.ebuild,v 1.1 2014/05/09 04:42:31 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} pypy pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN="IMDbPY"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python package to access the IMDb movie database"
+HOMEPAGE="http://imdbpy.sourceforge.net/ http://pypi.python.org/pypi/IMDbPY"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DISTUTILS_GLOBAL_OPTIONS=("*-jython --without-cutils")
+DOCS=( docs/FAQS.txt docs/imdbpy48.dtd docs/imdbpy.cfg )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6-data_location.patch" )
+
+src_configure() {
+ distutils-r1_src_configure --without-cutils
+}
+
+python_install_all() {
+ local doc
+ for doc in docs/README*
+ do
+ DOCS=( "${DOCS[@]}" $doc )
+ done
+ distutils-r1_python_install_all
+}