summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 22:05:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-29 22:05:17 +0000
commitcbf25ea4adf416d1ddf482f3913c4ba6a635a484 (patch)
treeb9580fcccad109a42d9ef3ef0d62327a8630c084 /dev-python/httplib2
parentUse -j1 for install (bug #283160). (diff)
downloadgentoo-2-cbf25ea4adf416d1ddf482f3913c4ba6a635a484.tar.gz
gentoo-2-cbf25ea4adf416d1ddf482f3913c4ba6a635a484.tar.bz2
gentoo-2-cbf25ea4adf416d1ddf482f3913c4ba6a635a484.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 14170-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog8
-rw-r--r--dev-python/httplib2/httplib2-0.3.0.ebuild17
-rw-r--r--dev-python/httplib2/httplib2-0.4.0.ebuild17
-rw-r--r--dev-python/httplib2/httplib2-0.5.0.ebuild54
4 files changed, 61 insertions, 35 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 4eb16f3f652b..9bb1bf717797 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.11 2009/05/21 20:39:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.12 2009/08/29 22:05:17 arfrever Exp $
+
+*httplib2-0.5.0 (29 Aug 2009)
+
+ 29 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -httplib2-0.3.0.ebuild, -httplib2-0.4.0.ebuild, +httplib2-0.5.0.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
21 May 2009; Brent Baude <ranger@gentoo.org> httplib2-0.4.0-r1.ebuild:
stable ppc, bug 269398
diff --git a/dev-python/httplib2/httplib2-0.3.0.ebuild b/dev-python/httplib2/httplib2-0.3.0.ebuild
deleted file mode 100644
index 7ff989af8aa5..000000000000
--- a/dev-python/httplib2/httplib2-0.3.0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.3.0.ebuild,v 1.4 2009/03/20 12:57:02 josejx Exp $
-
-NEED_PYTHON=2.3
-
-inherit distutils
-
-DESCRIPTION="A comprehensive HTTP client library with caching and authentication."
-HOMEPAGE="http://code.google.com/p/httplib2/"
-SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE=""
diff --git a/dev-python/httplib2/httplib2-0.4.0.ebuild b/dev-python/httplib2/httplib2-0.4.0.ebuild
deleted file mode 100644
index 5e7917bd5021..000000000000
--- a/dev-python/httplib2/httplib2-0.4.0.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.4.0.ebuild,v 1.5 2009/04/14 09:45:48 armin76 Exp $
-
-NEED_PYTHON=2.3
-
-inherit distutils
-
-DESCRIPTION="A comprehensive HTTP client library with caching and authentication."
-HOMEPAGE="http://code.google.com/p/httplib2/"
-SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-IUSE=""
diff --git a/dev-python/httplib2/httplib2-0.5.0.ebuild b/dev-python/httplib2/httplib2-0.5.0.ebuild
new file mode 100644
index 000000000000..e5a707636683
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.5.0.ebuild,v 1.1 2009/08/29 22:05:17 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="A comprehensive HTTP client library with caching and authentication."
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz
+ http://httplib2.googlecode.com/files/${PN}-python3-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ python_copy_sources
+
+ local dir
+ for dir in "${WORKDIR}/${P}-3"*; do
+ if [[ -d "${dir}" ]]; then
+ rm -fr "${dir}" || die
+ cp -lpr "${WORKDIR}/${PN}-python3-${PV}" "${dir}" || die
+ fi
+ done
+}
+
+src_compile() {
+ building() {
+ echo "$(PYTHON)" setup.py build
+ "$(PYTHON)" setup.py build
+ }
+ python_execute_function -s building
+}
+
+src_install() {
+ installation() {
+ "$(PYTHON)" setup.py install --root="${D}" --no-compile
+ }
+ python_execute_function -s installation
+
+ dodoc README
+ newdoc "${WORKDIR}/${PN}-python3-${PV}/README" README-python3
+}