summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-06-17 09:20:59 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-06-17 09:20:59 +0000
commit736667754bf34fa402499cef62676252a3e7de64 (patch)
treef36c3105317fb2fff11834efd32c829b203bc917 /dev-python/httplib2
parentInitial commit, wrt bug #457184 (diff)
downloadgentoo-2-736667754bf34fa402499cef62676252a3e7de64.tar.gz
gentoo-2-736667754bf34fa402499cef62676252a3e7de64.tar.bz2
gentoo-2-736667754bf34fa402499cef62676252a3e7de64.zip
Version bump httplib2 to 0.8.
(Portage version: 2.1.12.5/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog9
-rw-r--r--dev-python/httplib2/httplib2-0.8.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 9610378d7655..cc033b748bba 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.39 2012/12/30 20:25:48 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.40 2013/06/17 09:20:59 djc Exp $
+
+*httplib2-0.8 (17 Jun 2013)
+
+ 17 Jun 2013; Dirkjan Ochtman <djc@gentoo.org> +httplib2-0.8.ebuild:
+ Version bump httplib2 to 0.8.
30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> httplib2-0.7.6.ebuild:
Stable for alpha, wrt bug #447910
diff --git a/dev-python/httplib2/httplib2-0.8.ebuild b/dev-python/httplib2/httplib2-0.8.ebuild
new file mode 100644
index 000000000000..34d6175d1de5
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.8.ebuild,v 1.1 2013/06/17 09:20:59 djc Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux"
+IUSE=""
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_test() {
+ if [[ ${EPYTHON} == python2.* ]] ; then
+ cd python2
+ else
+ cd python3
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}