summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-06 09:00:35 +0000
committerIan Delaney <idella4@gentoo.org>2015-08-06 09:00:35 +0000
commitcee734bbcd1b8a1011e6a4bde3675f0f21f9dee8 (patch)
treefac63596b10c4c84baf76d42d2a828483175566a /dev-python/html5lib
parentFix install location. (diff)
downloadgentoo-2-cee734bbcd1b8a1011e6a4bde3675f0f21f9dee8.tar.gz
gentoo-2-cee734bbcd1b8a1011e6a4bde3675f0f21f9dee8.tar.bz2
gentoo-2-cee734bbcd1b8a1011e6a4bde3675f0f21f9dee8.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog7
-rw-r--r--dev-python/html5lib/html5lib-0.999999.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
index 71962bb4c3a5..34ba135cdb6f 100644
--- a/dev-python/html5lib/ChangeLog
+++ b/dev-python/html5lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/html5lib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.42 2015/08/01 06:29:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.43 2015/08/06 09:00:35 idella4 Exp $
+
+*html5lib-0.999999 (06 Aug 2015)
+
+ 06 Aug 2015; Ian Delaney <idella4@gentoo.org> +html5lib-0.999999.ebuild:
+ bump
01 Aug 2015; Ian Delaney <idella4@gentoo.org> html5lib-0.99999.ebuild:
add pypy3 support
diff --git a/dev-python/html5lib/html5lib-0.999999.ebuild b/dev-python/html5lib/html5lib-0.999999.ebuild
new file mode 100644
index 000000000000..1d6cb4c70ef8
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.999999.ebuild,v 1.1 2015/08/06 09:00:35 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}